Download

Opaque Decals

I want to create blood splats of pure red in my scene, but they have a transparent look to them.

i cant seem to find any tips of resolving this.

i have attached the offending splat

any suggestions welcome

Have you tried switching to dbuffer decals? To do this, enable dbuffer decals in your project settings, then switch the decal material’s type to one of the dbuffer types.

Ya if you are using baked lights enable dbuffer and then in the material settings select one of the dbuffer options that suits what you want/need. https://forums.unrealengine.com/showthread.php?1747-Best-way-to-make-blood-effects&highlight=blood+decal this thread is a little dated but it seems that my mats need to be reimported >_> though should help.

hi and thanks for replying. yes, dbuffer is enabled, and each of the dbuffer options within the shader gives me different, but bad results. i basically just want a cut out of the blood splat and ideally to have it most unaffected by the lighting…would it help if i add a screen grab of the shader?

splat 2.jpg

attached is the affect i want

Did you find a solution for this problem? I’m running into the same issue.

Yeah I’m having this issue also. No matter what I do, it’s always a washed out looking decal

Hiya, I had this same problem and this fixed it for me. Make sure these settings are checked:

8b26a075692053b142cd8c80962fa8e4b198a016.jpeg

See the full answer thread here:
https://answers.unrealengine.com/questions/25508/decals-not-rendered-without-direct-lighting.html

Same issue, none of the posted solutions works. My decals are still a washed up version of it.

I know this is an old thread, but ran into this, and this thread was the top google answer. For future reference, what’s missing from **lamwin **answer is that you need static lighting. In my case, I added a static skylight.

just use Decal blend mode “DBuffer translucent color”
20191001_222041.png

That also worked for me!

or DBuffer translucent color, normal, roughness if you have those maps and want them applied, e.g. from a Quixel Mixer decal import.

https://help.quixel.com/hc/en-us/community/posts/360006980598/comments/360001170217