Download

Opacity Map UE4 / Quixel Issue - Images Provided

Evening,

I’ve basically been advised to bring this to the UE4 forum as it’s more a case of bad drawing on UE4’s part (at least that’s my understanding currently). That’s only one issue, the other is I simply don’t get the results I imagine I would. I’m clearly doing something wrong I’m just not exactly sure what that is.

Basically I’m starting the texturing phase of a mini summer project and I’m having some issues with the glass material. I’ll admit I’m fairly new to alphas/opacity/translucency on the whole but otherwise quite well versed.

I’ve provided clear screenshots below showing what my problem is.

In Quixel

For this glass I added an opacity mask and added the ‘Windowed Glass’ material to the relevant faces. Here is how it displayed in Quixels 3D0 once I selected transparent mode (otherwise it’s simply solid):

ac00722f2bb50614272a1deab633b068b9c4636c.jpeg

In UE4

And here is a quick UE4 tutorial level with my asset/maps and a few lights thrown in. Basically the opacity map works to some extent when plugged into the ‘opacity mask’ option and I change the material setting to ‘Masked’ from Opaque.

What I’m going for is the Quixel look, I actually want to see the glass itself, you can see this is literally just see through there’s no other details making up the surface detail whatsoever.

59e7d1cdbfe6211e601a7a930e59a294c45b0675.jpeg

Here is the setup of my central chamber specific material:

247c38857db64e68385585dd70919ae3fbf1e777.jpeg

I’ve tried a multitude of things here such as Masked, Translucent (where things start going crazy, faces being seen that are behind and so on) options - even Opaque with my opacity map (which came from Quixel and was created with my Glass material) plugged into both Opacity and / or Opacity Mask.

I’d much appreciate any help so I can move onto my second texturing pass and wrap up this project.

Ah yes, I forgot to mention I also lose the roughness surface details entirely if anything displays at all resulting in a blur glitchy transparent section. Absolutely stumped.

Surely there’s got to be a straight forward way to do this in UE4?

Hello,

One suggestion you could try is bringing out the detail in your opacity mask. What I mean by this is that, naturally, surface scratches on glass make it less transparent. So, highlight the detail in the mask as a shade from black to white, depending on how defined each detail is, while leaving the rest of the opacity map mask as blacked out. Then, you should see different levels of opacity to get that partially-transparent-in-some-areas look.

Hope this helps

You’ll want to map out the glass as an entirely different material id in your modeling program and assign a separate transparent material to it. Unreal can’t really display opaque and transparent materials well within the same material, so splitting it up is your best bet. If you don’t need the window to actually be transparent you could try the “subsurface” domain, which will let light transmission be visible, but even then it’s probably better to eat the extra drawcall of an extra material then applying a subsurface shader to the entire mesh.