Download

Opacity and/or Alpha messing up rendering order?

I can’t figure out how to get these textures to render in the proper order 100% of the time. I have a tile material that renders a letter along with a dark backdrop (all 1 material) which is placed on a quad in a blueprint.

Then I have another blueprint that is also a quad with a transparent material that shows highlights (blue). The blueprint is placed just on top (about 0.02) in the Y direction so it doesn’t look far away. If I space it out to 0.1 or 0.2 then it will render fine but the problem is you can see that it is pretty far away from the tile material. I need to keep it at around 0.02 so it looks like it is right on top.

When I rotate my camera around the scene the highlight will pop in/out from time to time (2nd and 3rd image). Is there a setting I’m missing to make sure the highlight material always renders last or at least AFTER the tile material… or is there a problem w/a depth buffer and the precision of the differences in depth? How can I fix this?

Thanks!
-jv