One or more of the modules specified using the '-module' argument could not be found

Hi guys,

just downloaded and compiled UE 4.10 from github and created a new C++ project using the wizard. It works normally, starts its own editor, I can debug the code, all good. Unfortunately, when I try to compile the project when UE is running, I get the error from title in VS output.

I thought that maybe my setup is somehow wrong so I have tried to download a sample from Epic (the StrategyGame project), compile, run (without debugger attached of course), modify a line and recompile. Same result.

I then tried to just create the top down c++ project from the UE4 editor, with no modifications whatsoever, repeat the same process - same result.

The interesting thing is that it fails when trying to build the UE4 project (one that was NOT modified at all and buids just fine when building with the editor closed). The relevant output is here:

31>------ Build started: Project: UE4, Configuration: Development_Editor x64 ------
31>  Performing full C++ include scan (hot reloading a new target)
31>  Creating makefile for hot reloading UE4Editor (no existing makefile)
31>  Compiling game modules for hot reload
31>EXEC : error : One or more of the modules specified using the '-module' argument could not be found.
31>C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V140\Microsoft.MakeFile.Targets(37,5): error MSB3073: The command "c:\Dev\UnrealEngine\Engine\Build\BatchFiles\Build.bat UE4Editor Win64 Development -waitmutex" exited with code -1.

Any help would be hugely appreciated, restating the editor after every minor change is no fun!

Hi . I think you trying compile not your project you try compile UnrealEditor.

  • 31>------ Build started: Project: UE4, Configuration:Development_Editor x64 ------

In VS select your project game->yourProjectName, but you, how i understand select for build Engine->UE4.

Yes, I am indeed trying to compile the editor, as this is what I need to develop the game! I have the Development Editor configuration selected.

Sorry my english not strong. You say trying compile your project in Development Editor configuration. But in this line “31>------ Build started: Project: UE4, Configuration: Development_Editor x64 ------” i see not yours project i see UE4. You need select your project and set configuration to Development Editor.

On sorry for the confusion, that is just a snippet from the output, showing the project that actually fails. My game project compiles fine.

Actually, I have found that hot reload still works for my library! I was just confused by the build failing (which it probably shouldn’t, but what the heck)

I could be incorrect but just from looking over the error log, it looks like it’s failing because it’s trying to “Hot Reload” the editor/engine. As long as you are not making changes to the Engine/Editor code, you should not need to worry about it. However, if you are, you should close the editor before performing a new build.