[Official] Read this if your Download has stopped around 81%

UPDATE 5/5/14 - This issue is believed to be fixed on the current version of the Launcher. If you are still experiencing issues, please try the information below, and let us know if the problem persists.

Original Post

We are aware of some users who are still experiencing issues while attempting to download via the Launcher. This issue is generally that your download will become stuck around 80% progress.

Please refer to this post as the official Epic response to this issue. We will keep this top post updated with the current information and potential solutions regarding this issue. Please do not attempt potential fixes provided in other posts, as they are most likely out-of-date. If you are still experiencing the issue after trying the solutions recommended below, please post a single “Answer” to this post with the information that we request. If you need to provide additional updates, please only “Comment” on your original Answer.


CAUSE: We have a global timeout that is set too aggressively for slower connections, if 1 file takes longer than 3 minutes to download it times out and will attempt to retry it. Most of our data is chunked, and is usually under 1MB so that’s ok even if you have a really slow connection, however at this point in the download it’s attempting to download a 50MB file.


You can edit DefaultEngine.ini to increase the timeout value. You can find the file here: (c:\program files\unreal engine\launcher\engine\programs\noredist\unrealenginelauncher\config) and change the following section to these values:


Even after this change, the download may still appear to freeze for a few minutes, but please be patient and it should succeed momentarily.


If the above solution does not work, you might be able to resolve this issue by uninstalling UE4 and re-downloading the MSI from the UnrealEngine.com website. Please be aware that this will require you to re-download the entire engine (~8GB), and we do not recommend this solution for users with slow connection speeds or bandwidth limits!


Please enable extra logging so we can help debug the issue. Add the following section to the same ini file you changed before (DefaultEngine.ini)(without the numbers in front).


Attempt the download again, and then provide us with the logs located in (c:\users\YOUR_USER\appdata\local\unrealenginelauncher\saved\logs) by placing them in a ZIP file and uploading the ZIP here.

Please post a single “Answer” to let us know you are still experiencing an issue. Please provide the logs we have requested, as well as your Launcher’s Version number, which can be found in the bottom-left corner of the Launcher.

Thank you for your patience while we work to address this issue.

1 Like

I thank all of the Unreal/Epic support people who have resolved the issue of the updater stopping around 80%. Thank you.

The new installer solved everything for me too!

Thanks Epic for… everything!

Now, the “Subscribe” button appears to me and dont start the download.link text
Version: UnrealEngineInstaller-1.0.0-2039063.msi

Hi Edil,

We are still working on tracking down the cause of the ‘Subscribe’ button issue. I have a few questions.

  • Did you subscribe by credit card payment, or were you a custom case manually granted access by Epic?
  • Have you been able to launch the Editor previously, and the “Subscribe” issue has just started?
  • If Yes to the above, what changed between now and then?
  • Have you tried logging out and restarting the Launcher? (attempts at this have generally solved it for most users)


  • Credit Card
  • I never exceed 81%, I tried several times. Only in this version this button is displayed, before it was not.
  • The editor is a “News screen”? if yes, the images began to appear every attempt (in this release). I think before the content was loaded into the smaller screen.
  • yes, logging out, restart.


Thanks. And did you already modify your DefaultEngine.ini with the Http values I mentioned above?

Solved, starting the download now. :slight_smile: Thanks

Hello, update still stuck here… :frowning:
This is my .ini (i put high values in HTTP section, because trying with yours doesen’t work)








attached my log folder zipped

link text
please provide a permanent solution, this is going to grow as an annoying thing :wink:

thank you

I put in higher values, 9000 as you did, it seems to have fixed it for me, I am downloading now.

good for you.
mine is not working at all now

seriously, what’s going on?

Hi paolo,

Apologies for the inconvenience, and thank you for providing your logs. We are looking into the issue.

I had the same problem, but increasing the timeout values did not help. Neither running the installer with elevated rights and/or using the “-CPLabel=QFE2” switch.

To fix my installation problem:

  • I copied the installation folder to a different directory, as not to loose the update progress the application had made so far,
  • then I uninstalled UE4
  • and finally I reinstalled it to the directory location where I had copied the UE4 folder to previously.

The installation continued from the point where it previously blocked.

had to reinstall pc so went to do a fresh install of UE4 from website (UnrealEngineInstaller-1.0.0-2039063) says syncing account then just get a subscribe option and no option to download the rest of the editor software. Reinstalled 6 times to no avail, edited the defaultEngine.ini and still stuck at subscribe and i do have an active account.

Launcher version 1.0.0-2039064+++depot+UE4-LauncherReleases

I have attached my logfile ziplink text

Addition: I even tried using a full backup of a previous UE4 install and copied all files over to the new install, launcher updated and still ended up with only a subscribe option :frowning:

I’ve went through just about every solution I could find on the forums. I’m on version 1.0.0-2039063+++depot+UE4-LauncherReleases.

Here’s my logfiles

I’ve already put the higher values in the HTTP sections as well.

UPDATE: I have also tried to install via my MacBook Pro and it too just pops up with a subscribe button.

Trying to get installed on a second computer, but I’m only getting hit with the Subscription button, instead of install, my laptop downloaded and installed fine on Wednesday. Both computers have used the UnrealEngineInstaller-1.0.0-2039063.msi installer, with this second computer it never showed the download button, went straight to the subscribe button. I posted comments on another thread here, with links to a drop box file with 2 log sets, if they are of any use.

Here is the log file from adding the new log settings

Also: its very nice to see yall working on these issues so quickly, gives you faith in developers

If it also helps I put the DxDiags for both of my machines in this thread

Subscribe button appearing and not the Launch button. Have un-installed, re-installed, the above (changed timeout times) and same issues here.
Engine Installer version: UnrealEngineInstaller-1.0.0-2039063.msi
Attached are the log files for your perusal.

3804-subscribe+error+logs.zip (7.61 KB)

I am having the same issue as here it would seem. I am using the same version as here as well.
This is the zip file you requested in your reply above. Any help would be appreciated. I am ready to get into Unreal.

Version: 4.0.1-2039063+++depot+UE4-LauncherReleases

link text

Actually, mine doesn’t even download…it just installs the launcher and a shortcut…but no significant amount of the engine whatsoever is on my machine…any idea why? As soon as I select install…it goes on pretty fast and in about 10 seconds I have the launcher…but it only says Subscribe…which I have already using my Credit Card.