Official Level Sequencer fbx settings

Edit: is an extension of bug-like issue I posted here:
Video sequencer Camera FOV locked at 0. - Cinematics & Media - Epic Developer Community Forums

In Project Settings > Level Sequence, there’s a place where you can add additional fbx settings.

I added fbx setting:

  • FOV
  • CameraComponent
  • Field Of View

I then:

  1. made a level sequence
  2. added a camera actor to it
  3. imported a camera animation with FOV changes

It imports fine and the FOV changes update in sequencer and PIE.

But, when I upgrade the project to 4.16 the FOV gets locked at 0.

I’m concerned I’m not using the right spelling or case for the property names.

Is there an official list somewhere of all the valid level sequencer fbx settings? The default Focal Length one contains no spaces in the Fbx Property Name or Property Name. Yet in order to get FOV to work, I had to add spaces to the Property Name.

I looked around for official fbx settings and their respective format (capitals/spaces/etc.) but found no information whatsoever.

The fbx options you have here are the default ones that come with the engine - they convert the property with the name “Focal Length” to the camera component’s “CurrentFocalLength” property. They settings are here if you want to customize any other behaviors. For example, if you create some custom attributes in maya called “lightcolor” and you want that to convert to the light component’s “LightColor” property, you can do that.

Sounds like though, you have a separate issue - upgrading a project from 4.16 locks the FOV at 0. Do you mean the FOV gets set to 0? Does that happen within sequencer, on the track itself? Or does the camera have an FOV of 0 even with sequencer closed?

Hey Max Chen, thanks a lot for the reply and explanation of fbx settings. (and sorry to keep bumping the thread…)

I apologize for wording everything so strangely.

The co-worker that initially ran into the issue said, that in 4.15, the FOV custom behavior wasn’t getting imported with “FieldOfView”. He had to set it to “Field Of View” in order for the FOV to get imported. Since UE4 usually auto-inserts spaces in camel case vars that are displayed in Blueprint Nodes and Sequencer, I was hoping there was some official Property Name list somewhere.

To answer your questions:

  • Yes, upgrading a project from 4.15 to 4.16 sets the Level Sequence Camera Component’s FOV to 0.

  • The FOV for all of the key frames (in the sequencer) in the FOV track are set to 0.

  • The FOV during the camera animation is set to 0 even with the sequencer closed.

We can work around issue by reimporting the animation on a different track, copying all the keyframes and pasting them on the original track. But is a terrible solution when we got over a hundred of these animations.