Download

Odd Light Artifact

So I am having an issue when I build my lighting in my scene. Not sure what the heck is causing this. I thought it was something with the model, but after spending a full day going through everything in the model it has to be inside unreal. Anybody got any ideas on what is causing this?

It looks like a smoothing issue–where it would be trying to smooth the front to the side. You have the option to set up smoothing in your 3D program before exporting to UE4 or it can try to generate the smoothing on import.

If it’s a lighting artifact, then most likely you have UV’s that are overlapping or those faces are too small in the UV’s, you can try increasing your lightmap resolution for that mesh or improve your UV’s.

not sure what you mean by smoothing issue. Those are just flat faces, with the the normals perpendicular to the face. I am using Maya BTW

Every 3D program has a way to handle smoothing, for example if you have a cylinder with 8 sides, you want it to look like a smooth round surface instead of seeing each side as a facet. When things get exported to UE4, it has to know how the smoothing is set up, if you don’t import whatever smoothing is already applied to the mesh then it can generate its own by looking at the angles between surfaces though that doesn’t always give a desired result. In your case I’m guessing it is importing smoothing from Maya but the smoothing isn’t correct so it’s trying to use what’s there and the side face is trying to smooth with the front face, which you don’t want since it’s a 90 degree angle.

ok, I get what you are saying now. How do I export the smoothing with my mesh? I am using FBX export. Or is there a way to set smoothing thresholds in unreal?

There’s a smoothing option that needs to be checked in the FBX exporter in Maya, and then when you import to UE4 you want to make sure for the Normals that it imports the normals from the file (normals are the direction a vertex is facing which also controls smoothing)

ok, So i followed your advice and that seemed to alleviate the issue a bit. Though still not fixed. I decided to go back and rebuild the geometry and re UV everything. On a single shelf it seems to work great, On multiple shelves its showing some artifacting, then when I add a full shelf set the problem returns again. I am really lost at what is causing this issue.

487107fedd3de4ec4c7509d2dea9c569bd1c7cb8.jpeg

Is each shelf a seperate object or do you have multiple shelves in the same mesh?

It sort of looks like your lightmap UV’s are a bit off and you may need to create a unique lightmap UV for the mesh rather than let it auto generate inside of UE4.

Check out this page, has an awesome video detailing the issue. (Don’t worry about the video being for UDK, the same still applies for UE4).
http://www.worldofleveldesign.com/categories/udk/udk-lightmaps-03-how-to-fix-light-shadow-lightmap-bleeds-and-seams.php

Also. Worth reading the whole lot obviously but 3/4 of the way down the page, or search for “Contiguous UV’s and padding”.

I hope this helps, and that the problem isn’t something else.

Steamroller or auto unwrap for 3ds max!!! I don’t trust ue4 auto-generate lightmaps. AFAIK it uses the texture uv to generate the lightmap uv…and my texture uv always looks like s*it.

each shelf is duplicated from the same origional mesh, and the entire shelf set is saved out as a single object