Oculus with VR Preview in 4.10.1 not positioned right

Hi, I’m having trouble with getting the VR Preview to show the correct view in both left and right screens. I’m using the Oculus DK2 tih 0.8 runtime. I’ve updated my nvidia graphic drivers to the latest as well. The problem is that my right eye screen shows half a screen that is correct (as in, where I’m looking inside my level) and the other half is distorted geometry. Please refer to attached image.

The left screen is similar, but only the bottom half of the screen. It’s like the whole screen is offset and there is a margin running along the bottom and right hand sides that is showing incorrect views / geometry. Any help would be greatly appreciated! Thanks

I’ve tested on another scene and it seems to be working. So it’s just that scene above in particular that the VR Preview doesn’t show up properly for.- it’s the HAL Architecture Scene.

I am having a similar problem, the Oculus is having problems with one level of mine where the exact same problem appears.

Hi I’m having the same issue … if i package the game and use the tilde and “stereo on” command the same scene works fine. Other scenes work in the editor (v4.9 and v4.10). The two that aren’t working for me have many more assets and blueprints in them … but also have UMG interfaces; I wonder if that’s causing it … another clue is that when i packed the projects with UMG interfaces some parts of the interfaces don’t show up (they are potentially off screen).

Did any of you find a solution?


EDIT: one of the scenes that’s offset for me too uses the HAL architectural toolkit (and is not offset, but has a missing minimap, when I package it)

I am having the exact same problem in my project. Whenever I minimize the game it fixes itself on the Oculus but I cannot use any keys because the windows isn’t active. If I make the window active then the problem appears again. This is something really weird. The project has a lot of blueprints, models and particles. We ARE using UI’s in the scene although I am not sure what kind they are because it wasn’t part of my job and someone else did them. The Oculus works fine with other projects. I am using Unreal 4.9.2 and Oculus runtime beta with rift DK2. Unfortunately I cannot post any screenshots of the project just yet. Did anyone managed to find the cause of the problem or a fix for this?

Hi, I just tried minimizing the game to see if that would fix the rift … it didn’t on my system, but I did get the same problem with not being able to do anything as the window wasn’t active. I’m using an xbox controller, so hoped it might be different re the controls (it wasn’t). I do notice that the console commands don’t work when i use VR preview through the editor. Fullscreen and Stereo on don’t have any effect. They do when the exact same level is packaged though. Im using the same version of unreal and the oculus runtime as you; with Nvidia GTX980m’s. I’ve tried a range of drivers (it used to work fine) after rebuilding my machine and most have been unstable (unusual in my experience) so I settled on the 358.87 driver. what are you using?

We are using an Nvidia gtx 960 and the driver im pretty sure was 364.xx. I have also tried it also in a laptop with a crappy gtx 560M and the problem is exactly the same so I am discarding it is a graphics card problem. I found out that we are actually using UMG interfaces too. It seems that we all have this in common, maybe that is the problem and that would mean its just an Unreal Engine bug. We are generating the UI through code though. Tomorrow I will try the VR preview with the same project without any UI and see if this makes it work as it should. I will try to give an update on the situation when i have some time.

UPDATE - I tried removing all the UMG blueprints and it fixed it, you can now view the scene correctly. The problem now is that the UI is necessary and I have to find a replacement but I dont know where to start.

Someone solve this issue? I try 4.11 today, but the same bug happens… If I use a widget in viewport with just a bar, this glitch shows up in rift … :frowning: any clue?

Apparently Oculus is not prepared to receive these UI widgets on screen and it makes this bug visible. If you generate the UI through code at least the screen does not show this offset but it still has some problems related to positioning. This happens because you have a screen for each eye that shows only half of the actual game screen and it screws with the positioning of the UI. It is also considered bad VR practices to include 2D UI in Oculus games.
A solution I found for this is to generate 3D UI as ingame objects. Another solution would be to generate 2D UI for each eye through code. The UMG widgets will just keep showing this bug in Unreal. If you take the widget out of the game then the oculus should work fine, at least that solved it for me.

Hi limpit666 Thanks for your answer! But this is strange. I use duplicates widgets in rift before (in 4.8) without any problems…
After your post, I made some tests: I try the simplest widget (one button) and an event begin play in 4.8 and in 4.11, this was the result :frowning: apparently it’s a rift-full screen-widget bug… without widgets rift works fine. (gpu: gtx 970)

Hi Guys,

I found this very interesting, and looks like the way forward … https://www.youtube.com/watch?v=_veq6Q51Zlg

go to minute 16:20 to see the Unreal Editor in VR