Download

Oculus => when i move head i got shaking problem

Hello
When i move head with oculus DK2 i got shaking problem. i use unreal engine 4.5/4.7
i use I7/ GTX 970 with windows 7
thank in avance for your help

you must optimice you scene for get always 75fps.

it’s very simple scene(i get shaking problem even with unreal template basic scene)

yes its normal, UE4 have lot of things activate by default that kills fps in RV even in simple scenes.

My demo its more complex i got better framerate than in the basic template with a r9-290

SP 130 80fps
SP 100 100-110fps.

ins’t easy but its possible.

could you tell me wich things to take off for get good framerate ?
thank you

there are a lot of things you can do for get more FPS, and many depend of project or what do you want/can sacrifice

Generally the basic/easy its avoid or minimice the use of dinamic lights or dinamic shadows, if something have the word dinamic that going to mean “i will kill your fps in RV” :P.
You can get 10fps or more with Ambiente Occlusion off, but perhaps you want it, if you disable r.HZBOclussion 0 you can get another extra 10-15-20 fps…

There are more things and tricks but depends of the project and what do you want to do.

there are EPIC article about performance options in RV, google it and read it (there are things in that article that not work in my proyect and/or lost fps) , try one each time in your project with vsync off and check if FPS increase or no, and you must read generally alot about how increase performance / optimice / tricks / sacrafice rituals :smiley: and that things.

Type profilegpu in the console, that going to help you to see what take more time to process.

Always until you not known what are you doing, when you add something to your scene check your fps (with vsync off) and try search why that kill your fps. (if kill), its slow way of doing things but its a way for learning.

Generally the worst its on begin then you can add things without too much penalty in fps when you learning what work and what not work ok in RV.

You mention that you are using the Unreal template. Do you mean the normal template, or the Rift Template that can be found on the forums? If it is the first, I would highly recommend you get the Rift template, and see if that improves your shaking. The work I’m doing now is using this as the basis.

What runtime are you using for your Rift? I experienced the exact same problem, when trying out both versions of the engine in hopes that they would give me a better experience with the 4.4 runtime. No luck, I would get fairly bad performance on that same basic map. Rolling back to 4.2 and working with 4.6.1 works well for me. I do all my testing in Direct Mode. I’d really like to use the newest Rift Runtime, but I just haven’t gotten the performance that I want, and I just don’t like the idea of having to run in Extended Desktop.

I hope that helps.