Download

Oculus stuck on Floor (4.17)

My POV - oculus is stuck at floor level in 4.17. Everything was fine all the way from 4.10. with some fixes. But going from 4.15 to 4.17 sticks my eye height at floor level. Anyone know how to fix this? I have already tried using eye level. Thanks

I am also experiencing this issue.

I get similar issue, after 4.17 first launch and, please try to move your NavMeshBoundsVolume and cause to recalculate teleportation zone! You can see this zone select NavMeshBoundsVolume activate viewport (i mean get in viewport, you can hold right click and change position of view) pressing pand you have to see green area !

or go to project settings>engine>navigationmesh>generation>cell size and cell height will effect your possible teleportation zone.

I hope it will help you guys…

Cheers

Just started deving with VR again since i picked up the rift bundle last week.
Mine was fine at first,but then it was on floor every time after.

I solved it by opening the vr pawn BP and setting the Z height of the VR cam to 180cm .

I noticed that, thought it was my project so went back to 415. I am using - tracking origins as floor level, and Controllers - Hands are a spawned child blueprint if that is of any use.

make sure the name for oculus is “Oculus HMD” - this changed with the last update.

Thanks @AaronPaulina. This just saved me a lot of headaches.

You might as well lose the switch at this point… :slight_smile:

It’s still fubar though. You seem to be stuck at the height your HMD is when launching the game. The Floor level tracking seems broken.

Also, a freshly created project based on the VR template won’t even launch with 4.17. The loading screen spins forever…

The name is “OculusHMD” use no spaces. I should have thought about debugging through the problem sooner.

The loading screen took a long time for me initially as well. When I restarted my system and opened the project with 4.17 it went faster.

Thanks this post helped me. I had and have to fix a bunch of other things to get 4_17 to work with my project. The forward vector is now the right vector it seems. I have a AddForwardFromSelf and AddStrafeFromSelf functions which don’t make sense anymore. I can’t get the NAV mesh on inclines to work with my teleport increment move, I will have to fix the inclines now. So much migration frustration, maybe I should have stayed with 4_16. I wish the VR template was changed to make it so it has increment teleport turn, forward, and strafe and also have it work for inclines. Then I wouldn’t have so much trouble.

Are people still having these issues and are Unreal aware of them? It seems to be that if the game is started without the headset on, then I will be in the floor/where the headset was possibly initially tracked.

I had the same issue but renaming to OculusHMD solved it… Thanks a lot I’ve been struggling to find a solution…

Thanks a lot guys, this solved my problem I was struggling with for weeks now!! Now I can finally use the current version 4.17.2

Thks a lot