[Oculus Rift] VR Preview Black Screen

We tried the VR-Demo of the “Content Examples” project (and other projects), but whenever we hit the VR Preview button, we get a black screen on the laptop screen as well as the Oculus stays black after showing the health & safety warnings.

Furthermore we are missing the Display Mode option in the Oculus Confic Utility.

We are currently unsing Oculus DK2 with the SDK Version, Windows 8 and a NVIDIA 840M.

Update: We just located the error source. We deactivated the NIVIDIA GPU, ran with Intel Graphics 4600 and worked just fine. But we’d prefer using the NVIDIA GPU in order to increase the fps. Is there a solution?

Hello EnigmaticDragon,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project that is not the VR demo?
  2. If so, could you provide a detailed set of steps to reproduce this issue on our end?
  3. Could you check to make sure that the drivers for your graphics card are up to date?

Additional information:
Oculus has removed the display mode that you are looking for in the runtime. They are no longer supporting the extended mode that I assume you are trying to access. I hope this information helps.

Hey Rudy,

we just noticed that the official Oculus demos used the Intel Graphics by default. When we switched to the NVIDIA GPU, we got a black screen like in UE4.
So it seems rather to be a driver issue than.a problem with UE4.

Anyway, thanks for your help.

I am having the same problem with my Nvidia graphics card and after reading your post I also switched off my Nvidia GPU. Intel card just doesn’t even compare to what the 860 could handle as far as frame rate and everything. Did you ever find another solution?

Hello blakkfross,

Could you look over the questions that were asked to EnigmaticDragon, and post your answers in a reply?

Can you reproduce this issue in a clean project that is not the VR demo?
Yes, black screen comes up every time with Nvidia graphics card. The only way to remove the issue was by disabling the nvidia drivers and switching to Intel.

If so, could you provide a detailed set of steps to reproduce this issue on our end?

  • *Create a new project in Unreal 4.10.2 with Nvidia compatible graphics card.
    2. * Use nvidia graphics card with driver 361.43 and the latest oculus
    runtime 0.8 on UE4.10.2.
    3. Use VR preview mode with Oculus DK2 connected.
    4. Get black screen in preview mode with no video signal sent to headset
    and yet the blue LEDs will be on.
    5. occasionally get frozen corner of view screen.

Could you check to make sure that the drivers for your graphics card are up to date?
All drivers and hardware capable plugins are updated to newest version.

I was unable to reproduce this issue on our end. I was able to use the VR preview without issue. Could you provide your dxdiag?

link text

Thank you for the additional information. However, I was unable to reproduce this issue on our end with machines running Nvidia graphics cards. Would it be possible for you to test this issue on a device that is not a laptop? This issue does not appear to affect all Nvidia cards.

I am unable to use another machine that has all the drivers and necessary hardware. I am an independent developer with one computer and no other budget for the time being. I do not know anyone else with a Nvidia card on their machine either.

Have you been able to successfully run the VR preview on your machine in other engine versions?

No. Do you recommend any rollbacks to certain drivers? I have established the headset is working because when I use the configuration utility the demo scene always works without a hitch. None of the cables are damaged and neither is the hardware.

Hey blakkfross,

we didn’t give it a try for quite some time until yesterday.

The problem seams to be a incompatibility between Oculus Rift and “NVIDIA Optimus” and sadly there is probably no way to run Oculus with the dedicated GPU on a notebook, which uses this technology.

I guess the demo in the OculusConfigUtil only works, because it is using the integrated Intel graphics by default. Try right clicking OculusConfigUtil.exe → Run with graphics processor → High-Performance NVIDIA processor. You’ll see, there’s the black screen again.

I have an AMD r7 and an AMD 7880 both on my machine, I get a black screen with good audio in the RIFT as well. Not sure this is only related to NVIDIA or INTEL

Hello IronSatan,

Thank you for your additional information. What version of the engine are you currently using?

I am using 4.10.2 at the moment. I also tried it with a build of 4.9 with the same effect.

Also please note I am able to reproduce this in a clean project as well as my own project. All demo’s from VR work fine and the Configurator Demo for Oculus works as intended.

I can test. I am using VR preview. I never got Standalone to go into VR.

I have run a couple of tests on an AMD card but was not able to reproduce this issue on our end. Are you using VR preview or standalone? Also could you see if this happens in 4.10.4?

I can do that as well. Will take a bit because I am at work atm.

Would it be possible for you to provide your dxdiag?