Download

Oculus Rift DK2 and UE4 4.3: problems with Oculus Runtime 0.4

You’d need to get it from the Oculus fork on Github and build it yourself: https://github.com/Oculus-VR/UnrealEngine/tree/4.3

This should have no impact on your framerate. This setting will only help decrease your Lightmass light baking time (it tells Lightmass how many times the light should bounce around your scene). Visually - the difference between 1 and 7 should be significant - so I suggest rolling this setting back to 7 so that you get all of that nice bounced light back in your scene since it’s essentially free.

-Chris

Ok I suppose that makes sense. Not sure but it seems like it improved 5-10 fps and I had less jutter but then again its possible that was something else like the editor was open or something in previous tests.

I tried v0.4.1 oculus SDK/Runtime with unreal engine 4.3.1 , but I cannot get it to work… ****

Anyone has unreal engine working WITHOUT the whole github stuff…

Maybe I’ll just wait a week or two and hope it will fix itself :smiley:

At the moment recompiling UE4 4.3.1 with Oculus 4.3 branch on Github is the only way to get a workable solution. UE4 4.4 has some issues with the current 0.4.1. I am looking forward to see an integration of the latest UE4 4.4 with the latest Oculus SDK in the near future. Recompiling isn’t that painful but it is a nuisance.

Good news everyone! We have a fix on the way for Oculus 0.4.1 that will be integrating the ThirdParty 0.4.1 libs and headers and removing the old ones. Stay tuned to the announcements.

Yes it is very good news!

and usual question in such situation:

… when?

that is worth a usual answer:

…when its ready :stuck_out_tongue:

4.41 preview is actually up.

https://forums.unrealengine.com/showthread.php?30474-4-4-1-Hotfix-Preview!

Thank you for sharing a link

That fact drove me crazy as well. I was sure that it wasn’t a regular framerate problem.
I don’t know if this was already posted, but I finally found the solution to this strange stuttering during head rotations: go to your project settings and deactivate “smooth frame rate”. It’s under general settings.

In my case this solved the problem and now everything is smooth as silk.

Edit:

Sadly I got the same stuttering AGAIN. I didn’t change any settings since last time when it worked. It seems to be totally random. Sometimes I got no rotation-stuttering at all. This is driving me crazy…

Did,you check the frame rate? You can enter “stat fps” in the console to see it while in the Rift. IMO the stuttering just comes from <75 fps. This only really becomes a problem when moving the head, other movments don’t seem to be affected by it much.

If you get <75 fps, try “sg.PostProcessQuality = 0” in the console which seems to be the biggest offender for me. Try the other stuff under sg too.

Thanks Gigantoad.
I checked the framerate in two test-projects. One of them is just the starter map from the 1st person template, the other one is a piece of terrain with a starter material applied. The first one gave me around 68-72, the second one around 65-70. After I switched off all the sg-settings, it didn’t give me a noticable boost in fps, since the scene is almost empty anyway.

Do you really think the framerate causes the (quite extreme) stuttering? I swear that I had the very same test-levels running without stuttering sometimes when I was playing with the DefaultEngine entries from the ue4 wiki. But now I don’t seem to be able to reproduce it…

I am almost sure that it has something to do with how it is displayed on the rift. I.e. some experiences run perfect for me in extended-mode, and stutter in directToRift-mode. In general I can run all the experiences out there just fine. That makes me think that it is not just a regular performance problem. However changing between “pauseService”, “extended” and directToRift doesn’t seem to change much with ue4 (exept for the fact that the direct mode is deadly slow because of the mirroring)

I have a I74770k @ 4ghz, a gtx780 and 16gb ram @ 2666 mhz. And I am running ue4.4.1

I will try to oc my gpu now but I’d be grateful for any further ideas :wink:

disable postprocess not give me more FPS, sometimes less, you can disable some options for get better performance but not disable all.

Hm, Gigantoad really seems to be right. I overclocked my gpu and reached the 75 cap at all times in my two test projects. The stuttering is gone. But that would mean that even slightly dropping below 75 frames makes the game almost unplayable. Or is this somehow related to the rift being set to 75 herz?

Anyway… my problem seems to be solved - somewhat. The fact that we are talking about an almost empty scene here is kind of frightening :-/

The Rift runs at 75Hz so anything less will result in stuttering. And it’ll get worse as the first consumer version is supposed to run at 90Hz and even higher resolution.

Something isn’t right though if you’re struggling with a GTX 780 on a simple scene. I’m running a GTX 670 and with lowering some of the sg.* stuff can usually get to a constant 75 fps. I do use extended mode though as there currently seems to be an issue with decreasing performance in direct mode. Oculus is working on a fix AFAIK.

I use this: https://developer.oculusvr.com/forums/viewtopic.php?f=60&t=12486

Makes it easier to adjust settings and experiment, although it doesn’t currently support UE 4.4 so I compiled it myself into a custom editor. Sadly I don’t know enough about plugin development to get this to run stand alone or else I could provide it to people earlier (the creator seems busy but did mention he’ll compile it soon). There’s also this for testing, if you haven’t seen it:

https://developer.oculusvr.com/forums/viewtopic.php?f=42&t=12646

If you’re testing your own game you should package it and close the editor when you run it, at least just once to see if that helps with performance.

My current workflow that seems to provide pretty smooth results (GPU: AMD R9-290):

  1. OR setup: Extended mode (and display rotated to portrait in the AMD control panel and not set to primary monitor)
  2. Open project in UE4
  3. Under: Edit -> Project Settings -> General Settings: **Uncheck “Smooth Frame Rate” **
  4. Press the little Arrow next to Play and select “Standalone Game”
  5. While the game is loading Minimize the UE4 editor
  6. Once the game has loaded in it’s window press Alt+Enter

Game then plays perfectly in my Oculus Rift in full screen! I’ve no need to turn on stereo mode or anything like that in the console (tested with CoachKnights and a user made VR template found in these forums)

The most important steps for reaching 75FPS are 3 & 5!

Thank you!!!

finally achieved perfectly silky smooth performance. the setting that did it for me was Edit -> Editor Preferences -> Miscellaneous -> Use Less CPU when in Background. This is a per project setting.

Error work around…

So I found a work around for this error on OSX. You have to install the program successfully on a different computer in order for this to work.

Step 1: Copy entire ‘Oculus’ folder from the applications folder and put it on a thumb drive.
Step 2: Overwrite the computer you are receiving the error with the folder on the thumb drive.
Step 3: Restart
Step 4: Run /Applications/Oculus/Agent/ovragent

That’s it! Everything should work just fine. You will need to run ‘ovragent’ every time before running any Oculus program. I tried running ‘bash /Applications/Oculus/Agent/installAgent.sh’ in terminal to install ‘ovragent’ but received an error. So you will have to open ‘ovragent’ every time. Annoying, but at least it will work.

Hope this helps!

  • John