Oculus Rift CV1 tracking issues with 4.11.2

I just upgraded to 4.11.2 with my shiny new Rift, and I noticed there are some tracking issues with this build.
When I rotate/move my head around it all translates to the game camera, but with a weird offset that is hard to describe. Feels like the movement is not really 1:1 or that there is some weird predistortion on the shader that doesn’t work with the rift lenses which causes nausea very quickly. Could be the FOV issue as well…
Is there something I should set specifically for the rift in settings somewhere. All used to be fine in DK2 with 4.10.

Edit: funny thing is CouchKnights, Showdown, Realistic Rendering room demos work fine, but when I update my scene that I created with 4.10, I get this strange image warping when I look around. There has to be a scene specific setting that is new to CV1 and 1.3 runtime…

Ok, this is now solved. The problem is in the First Person Template. If you run it in VR (go up close to any of the cubes or bring in some extra static meshes for better reference) you can see that there is some weird image warping in there. While being close to any object look for example right and then down - instant nausea.

Turns out it has to do something with the camera. If I delete the camera on the character blueprint everything is fine. So it’s either a bug or a setting on the camera that causes issues in VR. I’d love to know which one it is if anyone cares to investigate. I was actually reusing this blueprint in my project hence the problem.

You might want to check this


I had the same issue but in 4.11 onwards you will need to add a scene component and then child the camera to it, just move the scene component to your desired height.

Hope that helps

I’m thinking maybe there’s a bug in the 4.11 refactored camera system. I’ve noticed the same subtle weirdness in position tracking in both DK2 and Vive, it feels like your eyes are 2-3cm in front of where they should be. So when you rotate your head, your eyes translate more than they should (which is most noticeable close to objects). I tried removing my camera component and letting the engine pick the view target, which seemed to fix the weirdness but I lose the useful features of the camera component. I’m also having the problem with the chaperone bounds being wavy not tracking right when using a camera component to view the scene.

Thank you for your replies, I got to the bottom of this. Turns out all you have to do is uncheck the “Use Pawn Control Rotation” under Camera Settings in your blueprint. Try it out, hope this fixes your problems as well, Beej.

That’s not the problem I’m having. I’ve done some testing and it seems like when a camera component is responsible for the view there’s a discrepancy between the chaperone and view transforms. The waviness people are having with the chaperone bounds might not be the chaperone being in the wrong position, maybe it’s the actual game camera being in the wrong position. The camera position is fine when not using a camera component, which leads me to believe there’s a bug in the way camera component transforms are handled.

I’m having a similar problem to you guys but it is driving me insane! I’m using the CV1 with the camera sensor properly calibrated. No matter what I do (add a scene component, tick/untick various boxes) when I start the map the view rotated (yaw only) 90 degrees to the left. No matter what I do I can’t get this yaw corrected using the component options via the viewport. I could try hacking it and rotating the yaw of the scene component by -90 on event play via the blueprint.

Has anyone else experienced this before. UE4.11 has really screwed this up!