Oculus remote input issues

I am getting no input response from the Oculus remote. I have the Oculus plugin activated, and have mapped the Oculus Remote Enter to an interaction, but the engine does not recognize the input.

I’ve tried a few of the work-arounds that were posted here a year plus ago, but none have worked. It’s really crazy to me that the platform has been around this long and there is still not a simple cohesive way to track inputs on the remote.

If you have the Oculus set up for touch it will invalidate input on the remote

I am having the exact same issue. Used to work properly with 4.16 and earlier. Is this something new for 4.17? There are plenty of use cases where someone wants the remote to still work even if the touch controllers are enabled. Any idea how to bring it back to the pre 4.17 behavior?

@JeffVRP I just found out this is actually due to a bug in the OVRPlugin (OculusInput.cpp) which prevents any input from the Oculus Remote from being properly processed and passed on to the engine. So this is not a normal/intended behavior.

I have fixed the issue and submitted a Pull Request for it.

https://github.com/EpicGames/UnrealEngine/pull/4030

Cheers,
Marco.