Download

Oculus Quest strange green artifacts

Oculus quest strange things.
UE 4.23 p7
I follow the instructions in this video: https://youtu.be/hEtu-ciPc7g I was able to successfully install the standard VR template on Oculus Quest, all the mechanics (tracking of the head and hands, buttons on the controller, and so on, work successfully), but there is one strange thing: when the application is launched for the first time, immediately after creating lunch through the menu, everything looks great.
but after closing, disconnecting from the computer and reopening, some objects and hands become covered with green highlights.
What am I missing?

I would use the Oculus Branch found on their github if you’re developing specifically for Quest.

I have this too. It appears to be random even time I start my packaged project. My first thought was that the reflection texture is corrupt. So I tried to remove the skylight in my level and it seems have fixed the problems. But like I said, it’s happens random so it might be still be there but I’m lucky it doesn’t show up.

TRY THIS: under the android build settings, disable OpenGL es2 and es3 and select vulkan. That should fix it.

The VR template has some unique .ini settings -

Try changing “r.Mobile.UseHWsRGBEncoding=True” to False in DefaultEngine.ini

Hi Alex,

This automatically gets changed​​​​​​​, so something may be overriding it. Could it be a shader/texture property forcing it to =True ?

did anyone found a solution to this?

Hey all, I got a bug submission in for this, so I took a look at it in 4.24 preview 1. ( Scalable quality, Mobile/Tablet , XR Enabled)

I had to disable Instanced Stereo in DefaultEngine.ini (known issue (fixed in preview 2) that will cause project to crash when opening)

But after disabling that and adding ‘Quest’ to that array, I was able to launch onto the Quest with none of those artifacts.

I tried changing values in DefaultEngine.ini but it changed nothing. This glitch appeared for me only on models with a little bit of reflectiveness.
Setting the roughness to 1 on those materials worked but when you need reflectiveness this workaround doesn’t fix anything…

Only this solution above fixed it for me !

Hi, i’m having the same problem with the green artifacts in my quest app.

I di not understand exactly how to fix the error. I try changing “r.Mobile.UseHWsRGBEncoding=True” to False in DefaultEngine.ini but and disable Instanced Stereo. Same effects.

For me the onlly solution was to disable multi-view (another bug along the “invisible” widget interaction component even when “show debug” is checked)