Oculus Quest LAN Multiplayer Connection issues

Hey guys,

i built a multiplayer setup in blueprint where the game is hosted on a Windos machine in LAN. When i join the session via UMG Widgets from another Windows machine everything works fine. The session is found from Oculus Quest as well but join session does not work. I read a loot of older post regarding multiplayer issues on Android but they should be resolved. Does anyone have any suggestions how to make this work? Is there any specifics to the Quest Headset regarding this or is it all Android?

Thanks in advance!

I’m working on a similar thing.

I had that problem as well but solved it due to my host session > Open Level options. I had it on “-listen” but they just needed “listen”.

For now I can host on my PC and join using one Quest that’s connected to the same wifi network.

My problem now is that when i want to connect a second Quest client, the host crashes and unreal editor crashes. I have no idea what’s wrong.

Do let me know how yours is going and if this helps!

I am also having an issue with Join Session on Oculus Quest clients trying to join a listen server. Everything worked fine in 4.22, then when I migrated to 4.23, none of the Join Session nodes calls are actually doing anything. Is this some kind of android permission issue? Anyone have this issue also?
I’m only using the standard start/join session nodes for local LAN play, not using the Oculus Online subsystem at the moment.

After testing for a few days I found out that indeed the Host / Join Session behaves differently in 4.22 than in 4.23 on the Oculus Quest.

I setup identical projects, checked the android intermediate manifest files for android permissions and such, and followed all the Oculus setup instructions. I even found out that if you don’t have Oculus Software installed on your PC that you can’t even see the OculusVR plugin options in Unreal 4.23! I only ever developed for the Quest so never needed it.
Both of the project settings are the same but they behave differently. I am able to host a session on the Quest, discover it by another Quest, but when I try to join it I cannot. The success pin even fires off the Join Session node when I try to join but nothing happens. How can it succeed when nothing has happened? I built the same projects out to Vive/Rift and if I host from a PC, I can join the server from the Quests in both 4.22 and 4.23. But as a Host, the Quest no longer works.

What has change with Oculus/Android related network permissions in from 4.22 to 4.23?

Hey, did you have any success with this? I’m having the same issues

I have a ticket submitted to Epic and they are helping me solve this. Once I get an answer I will be posting it here, Unreal Answers, and Oculus Dev Forums.

Anything new on this? I recently implemented the VRExpansion Plugin and what works is a Windows Host with multiple Quest Clients, but I can’t use a Quest to host anything and join in there.

I have been hounding the Support team every Tuesday since my ticket submission. Last week they told me the subject matter expert was on time off and would be back soon to look at it, this week I am still waiting to hear the latest update. Unfortunately, my team and I have had to go back to 4.22 because of this issue, which we regrettably didn’t catch until player testing two weeks into the migration efforts.

I have been visiting this post, the one on Unreal Answers, and on Oculus forums at least weekly and I will for sure update as soon as I get an answer.

Give it up to Turtle Rock Studios for this work around:

I’m still waiting to hear back from the Epic support team on this issue. Somehow, they did not find/fix this issue on the latest update the other day.

Progress is happening on this issue: Unreal Engine Issues and Bug Tracker (UE-82549)


I don’t know if my issue is related but, our project is using an old version of UE4 for quest, 4.18. It uses an Oculus Quest as a host, it works fine conneting 2 or 3 Oculus Quests, but it fails with 4. It always kicks another guest out of the room when it tries to join. Could anyone point me in the right direction? I think it’s something related with Android

Can you explain how to make Lan multiplayer connection. I’m just looking for the same. Thank’s in advance!!

Any progress on this?

It’s been fixed in 4.24.3!