Oculus Matchmaking Session Join Fail

The Oculus Platform SDK has a sample Unreal Engine project that demonstrates creating and joining matchmaking sessions and it can be opened with the launcher version.

I have been able to create sessions, but I haven’t been able to join sessions. Whenever a client clicks the green Start Matchmaking button, it never does anything - it just hangs on querying I guess. The Oculus library also has a blueprint node for finding matchmaking sessions that wasn’t used, but I added it with a Join session node and that didn’t work either.

I am developing with Unreal Engine 4.24 and I am using the Oculus Rift S.

Has anyone been able to get the sample project to work? Other people have had issues and mentioned techniques that worked for them, but none of them worked for me, such as uploading a build to the release channel.

Any success so far? We have the same issue, also does not work with advanced session plugin.

Yeah, a modification to the Online Subsystem Oculus Plugin was required. Also if you’re using the launcher version of Unreal and have a C++ project, I was able to copy the plugin from the engine directory into the project’s plugin folder and make the modification and use it in the project.

I updated IpAddressOculus.h as mentioned in the bug fix Unreal Engine Issues and Bug Tracker (UE-82549:)

Change line 186 in IpAddressOculus.h
(ToString) from: return
OculusId.ToString(); to return