Oculus HMD No Audio By Default

On the Oculus documentation, they say:

Note that when Unreal PC (Rift) applications are launched, if the OculusVR plugin is enabled and the Oculus VR Runtime Service is installed, then the application will automatically override the default Windows graphics and audio devices and target the Rift. The Oculus VR Runtime Service is installed with the Oculus app.

However, with my project on Unreal Engine 4.25, I need to set my default audio source to the Oculus headset, otherwise they come through the default Windows sound device. This is true for both the editor and standalone builds.

When I upgrade my project to Unreal Engine 4.26, the default audio source automatically changes to the headset.

Unfortunately, the project is not ready for Unreal Engine 4.26 for other reasons. Is there a setting or a function call that can use on Unreal Engine 4.25.4 such that audio enters the VR headset by default, like it does on Unreal Engine 4.26 (and games that you would find on the Oculus Store)?


I want to know where in the editor is “set my default audio source to the Oculus headset”, because I encounter that play packaged game on oculus rift s has no sound…althought I am using 4.26.2.


Oculus says it happens by default. In my case, simply updating to 4.26 made it work. Just tried it today with 4.26.2. No problems for me. That said, 4.25 still doesn’t work, so it doesn’t surprise me if you’d have the opposite problem with 4.26.2. Sorry. :\

When you say that it started working in 4.26, does the audio go to the hmd while using the editor? Or do you need to package and upload?
I tried upgrading to 4.26, enabled the plugins, but it’s still not putting audio through to the hmd.

I found the fix in 4.26 that makes oculus hmd audio work as expected. It is here https://github.com/EpicGames/UnrealEngine/commit/349842f4e8d39f461ba3610c1dbf1623871e9ec4