Oculus Hand Component crashes on play

Currently I’m trying to implement oculus VR with simple hand tracking for a quest 2 device.
Basic VR without any controls works fine but whenever I try to add the “Oculus Hand” component on my VR pawn the editor crashes when I press play.

What I tried and checked:

  • hand tracking support in project settings → Plugins → oculusVR on Hands only or Hands and controllers
  • Details of the oculus hand component → hand properties skeletal and mesh type set to the correct hand
  • creating a completely new project from the VR template

Those all did not seem to do anything. Any help to understand what the problem could be is very much appreciated!
Crash files are included.
UE5_Crash_Files.rar (154.8 KB)

1 Like

hi @SourceCodeVR
Seems you have crashes and fail to load in almost all the file.

Could you share an step by step of everything you did with the file?
Are you using any plugin in particular? why Oculus plugin if this UE5 runs properly the VR template. Did you tried it without any additional asset from your side? If not, could you?, if yes, what assets,BP, maps, textures, pawns, etc did you added?

Did you tried the attached template without touch anything to test it?
Are you trying it in a build or just in the Viewport + play
Are you using w10 or 11? Oculus software or any other?

1 Like

Thanks for the response @SimTecMD ,

Step by step for the project from VR template I did:

  • Make a new project from the VR template
  • Check if it runs without touching anything → it does
  • Set the project settings for Oculus vr to hands and controllers from only controllers
  • Add the oculus hand component and set values
    Just using the default oculusVR plugin to make it work with the oculus quest. The problem only occurs whenever I start trying to add hand motion controllers. If I delete them again the project is back to running without crashing.

I am currently trying to press play from the viewport, not building.
w10, default oculus driver software with air link

1 Like

let me try it during this week as you did

1 Like

Ok thank you for your help!

Small update on the problem: It is specific to Unreal Engine 5 as I tried to run the template with the same workflow as I used in UE5 but then in UE4 and everything runs like expected over there.

Is there a fix for this? I can confirm I have the same issue with UE5.0.


I have send in a bug report as I don’t think it’s an issue on our side. Maybe the more bug reports they get the easier they have finding the problem and fixing it so I suggest doing the same.
Otherwise just be patient I imagine.

Still stuck in your problem, hahaha
I’ll let you know if I can solve it :wink:

when you say “hand motion controllers” you mean hand tracking?

Maybe in this code you can find some solution, not sure. I’ll be in touch when I found something useful.

1 Like


I’ve been going in circles between 4.27 and 5.0 with a basic HandTrack setup that should work perfectly on 5.0 and it doesn’t. Although it works flawlessly in 4.27.

Everytime I start the VR Preview… UE crashes and prompts me this:

Has anyone solved it so far?

1 Like

This tutorial video is made in UE4 where the oculus hand component works fine. The problem occurs when you try to retrace the steps he does around min 5:15 in the video: adding the “oculus hand” component in UE5 and then running makes the engine crash everytime.
Unfortunately in UE4 this works fine but not in UE5.

Yes I indeed mean hand tracking with hand motion controllers :slight_smile:

Thanks for the extended help and time effort!

Sadly no solution found yet. I will keep updating this untill a solution is found by someone!


Glad to see my tutorial being shared :grin:. I am the developer of the hand tracking plugin and unfortunately the crash also occurs on 4.26 and 4.27. The difference is that on those two versions the crash only happens once every 20 times you play in the editor. In UE5 this actually happens every single time you play.

Has anyone reported this officially?



Hello, thanks for taking the time to respond! Great tutorial btw.

Yes I have submitted a bug report with as much detail as I could and included the crash reports.
So now it´s just waiting I think.

No problem at all. Thanks for the bug report, can you share the link to it?

I have not received any feedback on the report nor has it shown up in the issues tracker so I’m not sure where to find it at this moment. I’ll give an update if they get back to me or when it shows up in the known issues list!

Same problem here, downloaded the Just2Devs project which works fine in 4.27, but 5.0 crashes as soon as you introduce the Oculus Hand component. Hope Epic fixes this soon u.u


My workaround was to use the UE5 modelling tool to create my level, export the objects as .fbx and fixed whatever needed fixing in blender.

Imported to UE4 qith the working HandTracking Setup.

Not ideal, but until UE5 gets patched… It’s the way to go

1 Like

I have received a message that my bug report has been received and they have been able to reproduce it!
If anybody is interested in following progress on the issue:

I hope a fix gets released soon!


Hi, just had the same Issue. Read the description in the Issue and just wanted to add, that I also get the crash when ever the Oculus Hand Component is used in any capacity. It doesn’t matter if any skeleton or mesh is assigned or if the Inputs are set to “Hands and Controllers” or “Hands Only”. Even “Controllers Only” will trigger it.

Pls fix fast. I got a deadline coming up and to switch to 4.27 will take a lot of time for this project.


Managed to find a workaround in the meantime.
It’s still not fixed in Unreal 5.1 (UE5-main from GitHub).
However, Oculus has its own fork of UE5.
It works if you build the editor from there and set the OculusVR Plugin to the legacy backend.
There might be a way to make it work in the official version that’s downloaded from the epic games launcher (as the oculus runtime is just a plugin with c++ source), but I don’t have any more time to investigate this, we dropped hand tracking for now for our project