Oculus Go Motion Controller Help


Last week a friend and I started working on a VR project for Oculus Go involving architectural VR. We imported a Revit model with Datasmith into Unreal Engine 4.24 and managed to get the model running on the Oculus Go. We can look around the building model, change player spawn location and we managed to get the controller visible in VR and moving as it should. The thing we didn’t manage to do was setting up movement and teleportation in Unreal Engine. We’ve been looking at tutorials for how to set this up but it seems like our distribution of UE4 is missing some components(not sure). We cannot find any node associated with Motion Controllers(for example MotionController (R) Trigger which every guide suggests using). When we search for the node, or any other node involving Motion Controller, our list turns back empty. We’ve been searching this and many other forums and resources available on the internet for the last couple of days and still cannot find the solution to our problem. Are we missing any 3rd party SDK or software that will enable us to get the motion controller nodes and get the movement system in the VR running? Did we miss any steps in the installation? We followed the installation guides from both Unreal Engine documentation and few 3rd party sites and everything seems to work fine until this step. If anyone had the same problem or knows the solution, your help would be greatly appreciated.

Thanks in advance!

I am experiencing the same issue.
These are the steps I followed


  • Unreal 4.24.1
  • Oculus Go
  • Windows 10
  • Working and tested together

Steps to recreate

  1. Create new project Games, Blank Blueprint Project (follow the steps from the Oculus GO Unreal quickstart)
  • Mobile
  • Scalable 2D/3D
  • OculusVR plugin
  • No starter content
  • etc…
  1. Configure Pawn and controllers, following the steps in the “Creating Virtual Reality Walkthroughs”

  2. Add a Blueprint Pawn, named “VRPawn”

  3. Add a Scene

  4. Add a Camera to the scene

  5. Add 2 MotionControllers, to the scene

  6. Configure MotionControllers for Left and Right Motion Source

  7. Configure MotionControllers for Visualization Display Device Model default

  8. Add a Blueprint Game Mode

  9. Set the default pawn class to “VRPawn”

  10. Save and compile

  11. Play the scene, and launch it on the Go. No errors

  12. Open the “VRPawn” blueprint

  13. In the Event Graph, right click and type “MotionController”

Expected result
See options from
for GO controller, such as

  • MotionController (L) Trigger
  • MotionController (L) Thumbstick
  • etc…

Actual results
No listing for any MotionController (L/R) input.

Requested Action

Describe the steps required to be able to use a Oculus Go MotionController event in a blue print.



I found this in the release notes for 4.24.
I reverted to 4.23 and the MotionController (X) is there.

What are the mappings for the new “keys specific to each controller model” for the Oculus Go?

The Oculus page still refers to MotionController (X), even though the Oculus Unreal branch has moved forward to 4.24?

Is there other documentation that is maintained?

Unreal 4.24 Release notes

Action bindings that use MotionController keys need to be updated to use bindings for each platform the project is targeting. Blueprints that read MotionController keys directly need to be updated to use the action system instead.

Deprecated: MotionController keys are now deprecated and have been replaced by keys specific to each controller model.

+1, need to reconfigure buttons for Oculus GO

Thanks for the posts.
There is no MoveLeft or MoveBack BP included. Has anyone created this? I tried using the MoveRight/MoveForward vector and multiplying by -1 but it goes a bit awol.

Btw there is an issue with UE 4.24 and Go inputs so better to stay with version 4.23 or older.


in pre v4.24 motion controller inputs are generic so they can be used with any controller. It created issues when trying to build projects to be used by both vive and oculus, and you’d have to re-assign controls at runtime depending on users hardware. So now the inputs are changed to be hardware specific which makes it a lot easier to build inputs for both sets of hardware. Now when searching for inputs, search for “oculus” or “vive” instead of “motion controller”.
Also the "face button"s were renamed to match hardware button maps, so oculus uses ABXY instead of face button 1234, etc.

Eu fiz vários testes funcionais na versão 4.24 sem sucesso. Se alguém tiver algum vídeo de configuração de oculus Go por favor compartilhem o LINK.

I’m having issues with Oculus Go controller inputs too. Has anybody been able to fix this?

If you guys are all running on 4.24 be aware that the generic InputActions such as Motion Controller(R) trigger have been replaced with more platform specific names. For instance the oculus Quest and Rift S triggers are called Oculus Touch (R) Trigger and the Vive trigger is called Vive (R) TriggerTrigger. The oculus go could be called Oculus Go (R) Trigger or something like similar.

Also if anyone is looking at how to implement some features or systems and don’t know where to start from check out my free VR Content Examples project there are lots of examples including locomotion and teleportation.

Thank you for trying to help. Your example template looks exellent!
I tried to test your template, but I can’t get the Oculus Go controller to work. Controller shows up and moves correctly, draws laserbeam, but none of the buttons work.
I’m starting to be clueless here…

Guys am seeing issues on GO apps build with 4.23 or 4.24 after latest Oculus GO Device update. The screen is rendered washed out and also the splash screens! There was no issue before that update! Does anyone else has this issue? I have this on 2 games build on 4.23 , but those were released before months and this GO Update affected both! Please help!