Download

[Oculus Go] Basic project, 60fps to 72fps? [SOLVED]

Hello everyone,

UE4 4.19.2, Oculus Go

Using the BP from this documentation:
https://developer.oculus.com/documen…ced-rendering/

I cannot get the FPS to change to 72.0
Stat fps and “get current display frequency” are stuck to 60.0
https://developer.oculus.com/documen…l-dynamic-fps/
I use them in the level BP, tried also on the pawn BP.

Just to experiment I am using the project from this:
https://docs.unrealengine.com/en-us/…To/CameraSetup

What am I missing?

Cheers

It’s working as expected for me. Visualizing the output of Get Current Display Frequency gives 60 at the start of the experience and 72 after I have used Set Display Frequency to switch to 72 Hz.

Note that this won’t work if you do as PIE, it does work only when launching inside the Oculus Go. The UE4 Editor will keep reporting 60.0 FPS because this is the default FPS set in the project, but this is not indicative of the internal frequency of the Go.

The switch of MAX frequency is also confirmed by the Oculus Go diagnostic HUD. So everything seems to work fine on my side.

Try to use a Text Render component parented to the VRCamera or to the Motion Controller to display the current Frequency. What does it show?

https://www.youtube.com/watch?v=6WeXuplLXzw

Hello VR_marco,

Just to be sure:
I am using UE4.19.2 build from Epic Git repo.
(So not from Oculus repo)

This is a Screenshot from the level BP.
I tried also using the array (or set 72.0) manually. Same result.

I of course launch on the “pacific” (Oculus Go) device.

The set text is showing “60” (I duplicated the “text” actor in the level)

I tried also setting the fps to "fixed fps"in the project preference to 72.
Same result.

There must be something I am missing here, but it’s strange considering it’s project for Epic for GearVR.

I retried with a mint project from the Epic GearVR page and put the BP in the picture.
Same result.

My Oculus Go is a brand new “consumer one” (that I bought).

I am on 4.19.2 from the Launcher. Can you try to put a Delay (3.0 seconds) after Event Begin Play and before you Set Display Frequency to 72?

That works!

Delay of 3 sec and pop: 72fps!

That drove me nuts looking for a cause :slight_smile:

Do you want me to do a bug report?https://twitter.com/ID_AA_Carmack/status/992416612681568258

Thank you for your great assistance!

While I have you here, is there a way to enable Chromatic aberration correction within UE4? (BP ideally)

A delay of 0.01 also works!

I can’t find **Get Available Display Frequencies ** it says to enable (Online Subsystem Oculus in **Edit > Plugin > Online Platform) **after doing so and restarting i am not getting these functions… Any idea if they removed these for 4.21.1?