Oculus Entitlement Check 4.25

I’m trying to get the Oculus Entitlement Check to work on UE25, but it fails no matter what I do.

I’m following the Oculus VR Production for Unreal Engine course on the UE Online Learning, followed all the steps, but it doesn’t work.

Also followed the documentation on the Oculus website:


  • I created the App
  • Added the AP ID to the DefaultEngine.ini

  • Edited the Android.ini file
  • Enabled Develop mode from the mobile app
  • Disabled all the other Online Subsystems (except required by Oculus Sub System)

I don’t know if I am missing something else like username/id or secret token.

If anyone has a tip please let me know.


I have the exact same issue. I first tried this one year ago on UE 4.25 followed the steps just like you did. I spent a long time trying to figure this out and finally gave up. One year later, I’m trying this on UE 4.27 and I am still getting the same problem.
I have tried so many variations of solutions that I found online but nothing works. Is there anyone who can help set this up?