Occlusion Culling problem! Flashing lights

Hello everyone, I have an Occlusion Culling problem. I’m using version 4.26.1
It’s a BP Class (door). When it’s opened or I move around it causes light artifacts, flashes of light, as if it took a second to load something that should be there (Occlussion Culling).

bad options that fix it:

  1. If I disable this option in Options> Engine Rendering> Occlusion Culling, the problem is completely fixed. But, I shouldn’t use this option because I’m going to crash the game’s performance?
  2. when I remove any “fog” from the level, the problem also disappears.

I have tried all of the following:
Increasing the “Bounds scale” of static mesh -> It keeps happening. Any value.
r.HZBOcclusion, all options. Nothing.

Any idea What can I do?

Thanks a lot
have a nice day,

How are you increasing the bounds?

There’s a view mode option that displays the bounds.
toggle that on and make sure whatever value youbare changing has actual effect.

Second, the issue could be the door.
for instance, my doors are made of two meshes. Frame and door.

I’d have to bump up the bound of the door inside the BP in order to prevent the culling effect.