Object won't attach to mesh.

I have a mesh set to spawn at the location of my right vr hand. I am also telling blueprint to attach it so it moves, but it just stays put in the air. Yes it’s already set to moveable. I’ve tried every combination I can think of and nothing is working. Also I’ve looked for every post, and youtube video explaining this, and they are all either for 3d (not vr) or outdated. Any help appreciated thanks.

it seems like anything i “parent” it too, keeps it from spawning. I did try your way… no go

I believe that you want to attach it specifically to the MotionController component, not the Right Controller actor. You’re already using that transform to spawn the actor, so change your AttachToActor function to an AttachToComponent function.

Try changing the Collision Handling Override to “Always spawn, ignore collisions” and see if that helps.

If not, that sounds like there may be a separate issue going on. Putting a break point on the node immediately after the SpawnActor, does the spawn actor have a valid output at that moment? If so, then something else is destroying the actor almost immediately. If it doesn’t, that seems like a bug or like the actor is destroying itself on its own begin play.

If SpawnActor is set to always spawn in that collision handling setting, I don’t know of any cases where it shouldn’t spawn something, short of a bug.

I figured it out! Seems on AttachtoComponent I needed to have location rule set to Snap to target. I’m pretty sure I did that before but it worked yay!