Object normal map does not appear correctly

Hi guys I actually notice this problem of my object long ago, but I was kind of forgot about it until today I was modeling my model.

As the screenshot shows, why is the surrounding area stretched like that? I first thought that it was because my normal map does not have alpha channel, but when I import it into Gimp, it shows there is the alpha channel:

Is there a way to fix this problem? Will this effect my object appearance or game performance? I use Xnormal to bake the normal map by the way.
Here are more screenshot:

Thank you!

afaik it’s doing that to fill out the rest of the space of the texture. It shouldn’t affect your object as long as you have nothing UV’d in those areas. Also you don’t need to have an alpha channel on the normal map.

The best thing to do to make sure it works is bring it into photoshop or the equivalent and fill in the background with the neutral blue. Don’t worry about having the alpha channel either if you aren’t using it for anything, it would be taking up extra space for no reason.

Thank you Steve! So basically I don’t have to worry about it. I’m just curious why others’ don’t look like that. The normal map is filled with the blue background when it’s done baking though.
However, I just want ask you something more, when I plug in my normal map to my object (A rock), there is a obvious seam on my rock, is there anyway I can get rid of it? Or is it because I create the normal map in a wrong way?
Here are the screenshot:

Try double clicking on your normal map texture in the content browser and look for an option saying something like flip green channel. It could be that the green channel was baked backwards in xnormal. Also check if compression is set to something like tc_normalmap. I can’t remember what it’s called exactly.

Thank you Steve. I tried to flip the green channel, but it doesn’t work, the seam is still there, I also tried to adjust the RGB curve, it didn’t work too. I tried to find the TC normalmap option under Compression, but I didn’t find such a option, is it because I’m using another version of Unreal?


Ah they must have updated the names in the new versions…Let me have a look, it must be Normalmap (stuff) though.

Take the normal map off for a second and see if the line is still there. If it is there is a problem with your smoothing groups on the mesh. If there isn’t it is definitely the normal map!

If I remove the normalmap then there is no seam appear, I think it is the normal map for sure. I tried each option under the compression, none of them can remove the seam.

The problem must be with your bake then, have another look into your xnormal settings like edge bleeding etc.

Do you mean edge padding? I set it at 2, but it doesn’t work, there is still a obvious seam on my model. Now the only option I haven’t try is TC normalmap setting under compression, but I just can’t find this option there.