Download

NVIDIA GameWorks Integration

Wrong log in from me. Thanks!

Np, yw! :rolleyes:

Huge thanks to Galaxy Man and the NV team for getting all of this tech into the Unreal Engine!

I’ve built the Galaxy Man branch and then pulled in the sample level from the NV-official branch. I’ve noticed 3 problems:

  1. In the translucent surface material, there’s a broken node labeled “unspecified function”.
  2. My water renders as squares.
  3. The NV documentation says that the blend mode material used for the particles should be set to masked, however it must be translucent to use the scene color.

Are these related problems? Any solutions so far?

If there are answers to any of these questions already, please let me know. It would be nice to have a better home for all this info than 70 pages of forum posts :slight_smile:

Hey guys, I wanted to know if it’s possible to get interactive smoke using FLEX in UE4 (GalaxyMan’s build). Similar to the smoke in Arkham Knight and in the FLEX demo video https://youtu.be/1o0Nuq71gI4?t=55

I’m not concerned about real time performance here, will be rendering out a video for the final product.

Would also love to know wether Volumetric Lightning will be integrated anytime soon :slight_smile:

Yes, it is: https://developer.nvidia.com/NVIDIA-VXAO (see the details at the bottom of the page):

thank you for clearing this up.

i tried chesires console command and it works great.
the look is fantastic.

are there any values one could tweak?

NVIDIA HairWorks 1.2 alpha

And for people looking for volumetric lighting same place: https://github.com/NVIDIAGameWorks/VolumetricLighting

[SHOT]http://i.imgur.com/rhppHLt.jpg[/SHOT]

Page not found. Or it’s just for me?

Make sure your logged into github is all I can think of, as it works fine for me.

Strange. I have a github account and I can download/compile any other UE4 fork, including one from your signature. But page with volumetric lighting doesn’t exist for me. Can anyone else confirm this?

Yea this is pretty much the same situation I’m in.

It seems we should have a permissions from nvidia… Access GameWorks Source on Github | NVIDIA Developer . Will try

Edit. I got an email from nvidia, joined GameWorks and everything works now.

Thanks @Yura_s :slight_smile: I didn’t know that you have to join their organisation too.

Thank you very much!

Thank you very much!

Hi.

When i enable VXAO by writing r.VXGI.AmbientOcclusionMode=1 in the consoleVariables.ini the GI from VXGI disappear after i re start UE4 and the whole scene is black now…?, so, does VXAO does not work together with VXGI Diffuse Tracing or do i have to configure the settings in other way?

Thanks:)

VXAO is already included in VXGI. If you change the Ambient Occlusion Mode you simply disable the GI part so you only get the AO part of VXGI (at least from what I’ve seen, correct me if I’m wrong). So if you want VXAO and VXGI you don’t need to change anything and just enable DiffuseTracing and that’s it.

It’s weird because when I disable UE4’s SSAO, I don’t get any other sort of AO.
r.VXGI.AmbientOcclusionMode=1 does show the AO pretty well but when I set it back to 0 I don’t get to see any AO in the full shading mode.