NVIDIA GameWorks Integration

GalaxyMan2015, Thanks for the great efforts, dude.

Just tested your last 4.8 all-in-one build. All is great, except that VXGI Specular didn’t work at all. I used a copy of a project made with Nvidia’s 4.7.5 build, and it used to work flawlessly on that.

Any ideas??

It’s been about a month now since we got our hands on that first sample of hairworks. Any word on any developments? Can’t wait to see it with some more lighting features.

I’ve been trying to debug what may be the same problem. Specular works fine in the editor, but in the game it takes a lot more time to produce an incorrect result. Diffuse works fine in both. If I change the ReflectionApply shader to just output the VXGI specular buffer, this is what it outputs in game vs editor:


Just Realized that you have to remove ALL reflection captures from scene in order for VXGI reflections to work.

Very strange, and it was never mentioned in Nvidia’s UE4 VXGI documents.

Yeah I do recall having to do a similar thing actually, so when im testing VXGI, I have a level that has SSR turned off, no sphere reflections, and a skylight with a tiny intensity if any at all.

I have just noticed that in the latest vxgi release, SSRs don’t seem to be be working at all - even when turning off vxgi.
Is this the same with everyone else?

what? im on Galaxy man’s build and its working perfect. Speculars reflections are all working…

Why cant we bake light onto foliage like this to save performance? It would still look pretty decent even duplicated around if you can bake the leaf textures and blend between different materials based on tod, no? Why must the g.i. still be present and not be able to be baked into 1 tree and then duplicate that baked tree around without baking tons of trees at once?

Is this a feature that doesn’t exist yet? To bake 1 thing and be able to duplicate it with the lighting and bake information on that object intact without having to re-bake or bake it together?

For some reason I can’t get both SSR and VXGI spec to work anymore with this latest version, even when i make the modification to the shader code:
SpecularLighting.rgb += ScreenSpaceData.VxgiSpecular.rgb;

Yes I noticed that too. SSR gets disabled somewhere else earlier AFAICS. I dont know where.

oh… Screen Space Reflections right? I thought it supposed to do this. By the way why do you guys need SSR? when we have this awesome reflection?

My card is too bad to handle VXGI spec anyways but always know all your options. VXGI specular is quite unsharp isnt it? :slight_smile: Looks gorcious for soft polished things but if you need something sharper…

Dynamic reflection captures would be cool. (probably exist but Im too numb to know how to enable and use them)

yeah but it does the job :stuck_out_tongue: By the way i hate SSR with its pixelated result. Only thing that i love from SSR is floor, flat surface reflection :smiley:

You’re not alone, I also wonder if there is a way to get dynamic reflection captures, but haven’t found anything on the forums yet.
I’m not sure if it would work by just exposing the update functionality to make it blueprint callable, but might be worth a try? (I’m not a coder, so this is just a guess)

Hey guys, I’m running Ubuntu 14.04 and having trouble getting GalaxyMan’s merged version to compile. I’m mostly interested in the Flex integration, and Waveworks when it is available. Machine is dual Xeon E5-2640 with 4 Titan Blacks, CUDA 7, with NVidia driver 352.21.

On the Flex side, the supplied binary demo runs fine. Recompiling on the machine, however, seems to negate all of the collisions and all but convex meshes and sdf fall through the domain and pass through each other.

Is anyone else performing builds on a linux box with success?

Figured I would chime in with a +1 for Epic to implement plugin support for modifying the rendering engine. I have serious doubts about my skills as a github user and getting everything to play nicely. This would also be a huge benefit for the ArcViz crowd that may or may not be programmers. Going from AutoCAD / Inventor to UE4, and then needing to learn about github branch management and compiling? No thanks!

Please Epic!

Currently all the GameWorks branches are Windows-only.

@Galaxyman2015 > Could it be your build messes a bit with the new 4.8 procedural foliage volumes? They seem to be missing their boundingboxes as well as the simulate functionality. ‘Flex’ collision?

No, hadn’t actually tried them, so I gave them a go now and everything seems to be in order. I can see the bounding volumes, and the simulate seems to work fine.


thank you for your help we finally can play with the magic of nvidia.:o

and … is it somethings special need to known if I want to package my level(try a lot of times and even copy to other’s PCs,it still not succeed )