Download

Not possible to re-target animations to MetaHuman

In brief, it does not appear to be possible (at this time) to re-target existing animations to a MetaHuman. Using this tutorial, for example – in Retarget Manager > Modify Pose, only poses are available for specific body parts – no full body poses, thereby making it necessary to select “current pose”. There really is no other option.

The bones show up properly when re-targeting a blueprint / animation:

But as soon as re-target is hit, it’s clear the mappings are skewed, regardless of the humanoid defaults, with arms stretched across each other all the way to the ground and shoulders scrunched up to the top of the head. I am fairly new to this side of UE, so it could be I have misunderstood the procedure. But if you follow the tutorial linked above, as closely as possible, the re-target will not run successfully. Is there any way to get this working, or will we have to wait for a fix / update?

All in all, a very bad first impression. If the problems stopped at re-targeting, I’d be quite impressed with your amazing promotional materials for UE5 — but very basic things are broken. For example, if you migrate an asset from another project and add it, delete it, then put something else in the scene, it doesn’t matter how many times you save and compile, you will never get rid of that asset. It will forever be present in play mode. These are very basic things. I am surprised they escaped quality control prior to early release.

Hi there! :slight_smile: this forum is a bit of a ghost town - I would suggest posting in the comments of a tutorial for metahuman animation retargeting on YouTube. There are quite a few of them! :slight_smile:

I haven’t followed the official tutorial you listed, but have had no issues retargeting animations so far. Here are the basic steps if it helps?

Double click the BP of your metahuman in the world outliner. Click the Viewport tab. On the left in the Components tab, click the BODY and then on right of your screen in the Details tab look under MESH > SKELETAL MESH, double click on the icon. In the viewport of the editor, click on the “CHARACTER” button at the top and click on Bones then “All HIERARCHY“. Your Unreal editor will slow down but that is normal. In the top right, click on the SKELETON icon. Now, a tab called “Retarget Manager” will be open on the left side of the interface. If not, click Retarget Manager on the top ribbon. Under SET UP RIG, click Select Rig “Humanoid”. Click SHOW ADVANCED. If anything is under the IK options, click the X to turn them off. Now, change the tab to the “SKELETON TREE“. In the top left of the tab, click on OPTIONS then enable “Show Retargeting Options“. Change the root and the pelvis to “Animation“. Then, hold down shift and select all the other below, then right click and choose “Recursively Set Translation Retargeting Skeleton“. This will change them all to the Skeleton option under ‘Translation Retargeting‘. Now clickSAVE in this editor panel and you can close it to return back to your main “BP” editor panel.

In the content browser, select the animation you want to retarget (as long as it uses a humanoid skeleton; if not you need to first set up its retarget settings to humanoid just like the above steps for metahuman) then right-click then choose “Retarget Anim Assets > Duplicate Anim Assets and Retarget“. A new dialogue box will appear. On the left side, click on “metahuman_base_skeleton“. Then click the “Retarget…” button on the bottom of the dialogue box.