Download

not find DataSmith ..

Guys I can not find the DataSmith Plugin in UE4 beta … (vers 4.21.1) is driving me crazy. I find it in the Plugin list. it’s the second time I reinstall UE4.

from here I downloaded the export plugin for 3D studio max. but nothing in UE4 I do not find it.

thanks for those who can help me.

Hello.

I have moved this topic from the ‘Marketplace’ forum to the ‘Unreal Studio’ forum.

I have confirmed that you have joined the Unreal Studio beta, so you will find the Unreal Datasmith plugin on the Epic Games launcher by navigating to: **Unreal Engine (on the side bar) > Library **(on the top bar)
And then scrolling down to the Unreal Studio Beta section. Then click Install to Engine.

You can confirm that the plugin has been installed by clicking on Installed Plugins underneath the engine slot on the **Library **page.

Once you load the Unreal Editor, you will see the Import Datasmith button up top.

Just in case the plugin is installed, but you do not see the button, in the Unreal Editor navigate to Edit > Plugins > Unreal Studio. You might see that some of the plugins are grayed-out and can not be enabled. If this is the case, you will probably have a message near the bottom of the window saying that your project is not an Unreal Studio project. Click the ‘Convert and restart’ option. This should re-load the editor and allow you to use the Datasmith plugin.

Stephen Ellis thank you for answering me … I went into Edit> Plugins> Unreal Studio I selected Datasmith and restart but I do not see the button.

It looks like Datasmith is not installed to your Engine.

In the Launcher, on the Unreal Engine > Library page…click on “Installed Plugins” underneath the Engine slot. What do you see?

… here?

they are equal?

I think the problem is this.
I am also attaching the pdf guide to the installation.

this is the last one I think: https://api.unrealengine.com/attachments/Enterprise/GettingStarted/DownloadingUnrealEngineandInstallingDatasmith.pdf

this is old but I think explain better your problem: https://drive.google.com/file/d/1OS9wUPPvH3fqqp841kiAuByNtxeGxjhh/view?usp=sharing

nothing here too …

I see the problem.

You have 2 Epic accounts.

  • Nokilop
  • Nokiop

You are logged into the forum with one account, and that account has registered for the Unreal Studio Beta.

You are logged into the Launcher with the other account, and that account has not registered for the Unreal Studio Beta.

**Stephen Ellis YEeeeeeeeeeeeeees!" :smiley: … haaa i’m stupid I have several accounts ! XD THAAAAAAAAAAAAAAAAANKS ! THAAAAAAAAAAAAAAAAANKS ! THAAAAAAAAAAAAAAAAANKS ! THAAAAAAAAAAAAAAAAANKS !

Thanks :)))))))))))))))))))))**

i have a similar issue

Not exactly similar. You have not joined the Unreal Studio Beta. You need to do that first - https://www.unrealengine.com/en-US/studio

Very detailed steps to solve the problem. thank you!

image: https://www.pinclipart.com/pindetail/Thbowh_thank-you-script-thank-you-script-png-clipart/

Beta over, bad link ? Plugin enabled in 4.24 but not icon on toolbar. How does one therefore use datasmith . I’ll try disabling, re-enabling and hope it fixes something. If not I’ll update this.

Hi neighborlee. I recently answered you over on the Answerhub (Datasmith options missing in 4.21 - UE4 AnswerHub)

I’ll go ahead and add additional information here:

  • If you are using the new UE 4.24 version, then Datasmith is automatically included in the engine, and enabled depending on the type of project you create. For other project types, it can also be enabled from the Edit > Plugins > Importers menu.
  • If you are using UE 4.23 or earlier, then Datasmith exists as a separate plugin which can be downloaded from here: https://www.unrealengine.com/marketplace/en-US/slug/unreal-datasmith. The plugin will need to be installed to your engine version via the Epic Launcher.
  • Both any scenario, if you are working with 3ds Max, SketchUp Pro, or Revit - you will also want to get the exporter plugins from here.

Desperate for answers to keep going I posted here as often questions go unanswered on any given forum. I know it must be a little exhausting to *keep up. I don’t enjoy ‘double posting’, its just a little frustating when posts go unanswered for long periods time, understanding * .

Using 4.24 now, ok good to know its automatic in 4.24, so why is no icon for datasmith on toolbar , or is that also new ?

Just making sure to get the best possible ,easy as possible imports;)
Btw, its not under edit>plugins>importer menu , all I have and enabled is datasmith content. Is that it or litearly just content FOR the plugin, Very confusing.

Thx

Sorry for the confusion. Did you create your project new in UE 4.24? (if so, which category & template did you pick?) … or did you open a project that was made in an earlier engine version?

If the Datasmith importer is not automatically enabled, then for the plugins to enable, you will want to enable the “Datasmith Importer”, and potentially the others depending on the file formats you intend to import. (“Datasmith Content” is a default for reading files which have already been imported) Afterwards, you will see a little prompt at the bottom:


Choose “Restart Now”, and when you load the project on restart, you should see the button in the toolbar.

I started project somewhere around 4.18 or possibly earlier and upgraded as I went, and upon checking ‘importers’ left side of plugin window, there is no such item named datasmith importer , to be sure I checked every category and nothing showed up for datasmith importer.
Is there anywhere else to check what might be causing this importer not to show up ?

TY

Please upload two screenshots.

#1 - Help > About Unreal Editor
editorversion.jpg

#2 - Edit > Plugins > Importers > ‘datasmith section’

Thanks

Sorry I didn’t respond earlier went on an errand, so anyway my mistake apologies I was starting with 4.23 and it didn’t error out so I started 4.24 and all good. ty for your effort as always.