Not able to build project from 4.7 to 4.8 , 4.9, 4.10

Hi guys !
I Tried to upgrade multiple times a project to a higher version but every times it’s not working , I still have the same error ( see the screenshot) . I tried multiple ways including searching a solution on the Internet and here but nothing worked. I’ve also cleaned , re-install the projects files multiple times and re-install/cleaning VS studio 2013 /2015 and the engine itself ( 4.8 , 4.9, 4.10 ), but I still have the issue an nothing work. The only way to have a successful build is to use the 4.7 version.

If you guys have any idea to help me solve this issue it would be wonderful , I really need to upgrade this project , and I can’t just restart it and rewrite everything.

Have a nice day !

Hello Madness,

Whenever you see “Other Compilation Error (5)” or any error message that doesn’t make sense to you, it is best to look in the Output tab for the entire error message. Can you post what is listed in the output log in a text file? The current errors that you have taken a screenshot of are too broad to diagnose the problem.

Hi , here is the ouput log

1>------ Build started: Project: Dystopia, Configuration: Development_Editor x64 ------
1>  Creating makefile for DystopiaEditor (no existing makefile)
1>  Performing full C++ include scan (no include cache file)
1>  Parsing headers for DystopiaEditor
1>    Running UnrealHeaderTool "G:\Projects\Dystopia\Dystopia.uproject" "G:\Projects\Dystopia\Intermediate\Build\Win64\DystopiaEditor\Development\UnrealHeaderTool.manifest" -LogCmds="loginit warning, logexit warning, logdatabase error" -rocket -installed
1>  G:/Projects/Dystopia/Source/Dystopia/Bullet.h(43) : Type 'int16' is not supported by blueprint. Bullet.initialSpeed
1>Error : Failed to generate code for DystopiaEditor - error code: OtherCompilationError (5)
1>  UnrealHeaderTool failed for target 'DystopiaEditor' (platform: Win64, module info: G:\Projects\Dystopia\Intermediate\Build\Win64\DystopiaEditor\Development\UnrealHeaderTool.manifest).
1>C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V140\Microsoft.MakeFile.Targets(37,5): error MSB3073: The command ""G:\Epic Games\4.10\Engine\Build\BatchFiles\Build.bat" DystopiaEditor Win64 Development "G:\Projects\Dystopia\Dystopia.uproject" -rocket -waitmutex" exited with code -1.
========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========

Seems that int16 is no more supported , I will work on this and see if it works by correcting this

Edit : it’s working now, I add to replace int16 by int32
Thank you for the output idea , I didn’t know where to look for having more details about the error . Now it’s working on 4.10 with VS15 :slight_smile:

If I recall correctly, you should be able to use int16 but not for variables that are marked as UPROPERTY as int16 is not supported by blueprints, as the error says. I’m glad that you were able to find the issue however.

Have a nice day!