Download

Not a good grass

I’m creating a scene and I wanted to achieve certain realism on it, but my grass setup is only looking good when the normals are facing the sun lamp, any ideas about how can I make this look better?

Grass with the normals tunrned to the sun

14ad353717a5b6c65ab80137bee16c3a4100e0dd.jpeg

Grass with the normals on the oposite direction of the sun

material setup

d8356a6ea77cbd2b810422ecff1801747f6f3ac2.jpeg

Are you using the two sided foliage shader?

Yes, Its two sided foliage, but I’m not using two sided materials for the grass, the results with it looked way worse.

Is that 0 constant plugged into all three channels (Metallic/Spec/Rough)? If so, trying plugging a 1 into rough (leave the other 2 at 0).

Thanks Kirik, i did that as you suggested, but kind of didn’t changed too mutch unfortunably, it’s still kind of dark in one side and looking good on the other.

Why you have anything in emissive channel? You need to setup opacity channel if you use two-sided foliage model. For normals I suggest you to just make it point same direction as surface.(worldspace up.) Then it will look nice from all direction and it looks just like underlying landspace.

Yea I would do what Jenny Gore suggested, but control it with a Lerp, with a scalar parameter so that you can blend in a little bit of the actual blade normal. Also I would try playing with the opacity value as well as the basecolor and subsurface colors. Sometimes its necessary to make the basecolor a bit darker and the subsurface color a bit brighter.

Didn’t see this mentioned, but is this for static or dynamic lighting? Only dynamic lighting really works correctly with subsurface lighting models.

Thanks a lot for your help guys, i changed a the settings as you guys mentioned and now its way better, the subsurface brighter color was what helped most, by the way the light of the sun is dynamic.

Thanks a lot!