Normal Maps: Flip X and Y?

Here’s my current UDK workflow:
I keep all my normal maps +(X,Y,Z) so they render correctly in Maya and then use invert Y during UDK import so I don’t have to have two copies of a texture.
Importing into UE4 now and they just don’t look right so I find the setting for FlipY in the texture properties. But it still looks bad. I add a multiply(-1,1,1) and now they look ok though I’m not sure yet what to expect visually with the new PBR rendering evnironment.
After a preview lighting build the normals look correct.
So am I correct in that both the green AND the red channels have to be negative for UE4? If this is the case is there a setting somewhere that I can enable so that it does this automatically during import so I can stay in my comfort zone of having all my source art be in one format?

No, only the green is negative just like in UDK/UE3. Thre might be something wrong with your test assets or setup.

Red should highlight from the Right, Green should highlight from the bottom. I just look at my channels in photoshop when they’re baked out and invert as necessary.

Seems to be intermittent problem. Maybe I need to update driver. I have version waiting to dl in geforce exp. Could also be some other programs I’ve installed have borked something.
Thanks for the replies folks. :cheers: