Normal Map Seams

Hi, Normal Maps have been causing me a lot of issues in UE4, and I’ve been trying to figure out how to get rid of the seams to fix this. I have been avoiding creating UV seams whenever possible, but sometimes it can’t be helped.

To illustrate my problem I have created a sphere and cut the UV’s in the middle. Here is my result:

I create my Maps in Mudbox, and have tried extracting maps with every possible option. The Normals display properly for me in Mudbox and Maya, but I have noticed that the normal maps I create look inverted across the seams. Here’s the map I’m using on this sphere:

Am I missing something, or doing it wrong? Thanks for your help!

Just a note, this is happening to every model I create.

1.Flip the y maybe? or green channel
2.Also try open your material select your normal texture and see what its sample type is under material expression texture base. I have seen it glitch to color instead of being set to normal.
3.use jpgs instead of pngs.

Hi Daphnis26,

Make sure your Compression Settings are set to TC Normal Map instead of default in your Texture File in the Content Browser. You may also need to reverse the green channel in your image file. Also Targa (.TGA) is the preferred image format.

Let me know if any of these suggestions fix your issue.

Thanks

UE4 looks at the first UV channel for its Normal tangents (basically where/how light touches it), it could be that one half is rotated and therefore the light that touches it looks inverted.

Also, thats a very nice tree model!

I’ve found a custom solution for this issue: go to properties of your normal map texture, set compression to tc normalmap, and change randomly the “RGBCurve” until you got thedesired result.

There’s a pic if you don’t understand me.

However, I don’t the “TC normal” option under the compression. Is it because I’m using a different version of Unreal?

58306-no+tc+normal.png

Hi ALTWang,

The setting you have hightlighted used to be called “TC_Normalmap” where the “TC” stood for Texture Compression. This is the correct setting for importing normal maps.

Steve,
I see. But the seam is still there even after I filp my green channel, and select the Noprmalmap DXT5 option in the compression settings. Any ideas?
I use Xnormal to bake my normalmapsway.

Can you send me a blank project (please don’t send a large/entire project) with the texture imported and where the seam is giving you an issue? You can attach it as a zip file here, via dropbox, or send to me as a private message on our forum. -Thanks

Was this ever resolved?

Yes, I do not know why AnswerHub is posting “0 Answers” but the answer I posted has been accepted. If you are experiencing a similar issue, please start a new post and include screenshots. We may request your native files to see if they are set up correctly as this has not been a widely reported problem.

It is not a problem of the “Normal” texture. In the image I show you, only the “Base Color” is connected and the problem persists. Before activating “compute skin cache” it was perfect. The solution would be to put hair on the character to cover the error. Unfortunately this character is bald. This problem has not been solved for 4 years. And now in 4.25.4 it is more serious than in previous versions.
[1]: https://drive.google.com/file/d/1RvE53aghLMXzAZsInPBlGjg6uJG184ap/view?usp=sharing