Download

Normal Map on Skin Displaying Incorrectly

I am running into an issue with a character I am building, the skin is looking incredibly rough and unnatural. I am basing the material off of the “A Boy and His Kite” demo that was released recently from the GDC presentation.

Here’s what it looks like in the editor:

I have a Subsurface Profile being used on the character, with the default settings
Scatter Radius - 1.2

The Opacity is being driven by a texture map defining the thickness of the features.

I have a single spot light on the head, here are it’s settings:

Here’s what I have for the normal map settings. I have tried this with a** tga, png, exr**, and **tiff **(converted to psd) file formats, all of them net the same result.

For those that are curious, here’s a close up of the sculpt in Zbrush

If I have a setting set incorrectly, I’d love to know! And, if anyone knows good resources for skin tutorials, I’d be grateful for a link!

Try flipping the green channel.

^This

It looks like you’re using OpenGL normal map, UE4 uses DirectX. Basically just invert the green channel (this can be done in photoshop, just open the normal map and go to the channels tab, select the green one only and invert it)

That will orient your normal map correctly, but I don’t know how to fix the over roughness, that looks related to the material settings. But I suggest fixing the normal map first, then adjusting the materials later if it still doesn’t look right.

It still looks bad with a flipped green channel, as seen in this gif I made

Any other thoughts?

The normals look better now, but I think you need to play with the shadow bias.

You can try this to adjust your normal map intensity.

b49e39ed042cb7c4491c46c54ee58afe8c87b74c.jpeg

You definitely should not adjust the normal map intensity on a baked normal map. Its fine for tiling normal maps or detail normal map, but for a baked normal map that isn’t flat or trim textures, it can create incorrect shading.

^ Ahh, good to know!

The normal map finally looks like your sculpt now, but the intensity seems a little high.

But the specular/glossiness is really making it look hard and plastic, do you have a spec/roughness mask made yet?

I haven’t made other maps for the character yet, I’m still not finished with the sculpt either. I was just wanting to do some tests for micro skin displacement before I went ahead and started to finalize the character. This is pretty much my first time into UE4, so there has been a pretty intense learning curve in the last week or so.