Download

Noooooo! Are Materials set to the Volume Domain incompatible with Niagara Meshes?

My subject says it all. The works with Niagara checkbox in the material Details is greyed out when the Material is set to Volume. I nonetheless tried to add it to a Niagara mesh and then it broke the material saying some volume bound thing was undefined in the material log : /

I made some clouds using a volume material and i want to put it into a particle system. Any ideas?

Here’s the first error the Stats window gives me in the Material when I check Used with Niagara meshes:

I actually have the same error, I was making as well a material intended to be used as volumetric fog within a particle systeme, I end with the same error as you.
The weird thing is that i have a tutorial project that i was using to learn how to make such material (it was a 4.19 project upgrated into 4.25) this one is working fine, then tried to import the content of the tutorial project into mine to check, and there the material break and give the same error.

So I tried with a fully new clean project and redo by hand the material from the tutorial project, again same error, I obviously used the launcher to check if there was no issue on the engine itself, no issue found.

This issue is a complet mystery for me.

EDIT: I found the issue on my side, it was plugin related, Gfur Pro was causing the error, will report the issue immediately to them.

Hi, thanks for letting us know. We have already fixed the bug and will submit update today or tomorrow.

Update is out that fixes the issue. And there is a new curl brush.

I’m getting the same error, and I don’t have Gfur Pro :frowning:

I’m still getting this same error in 4.26 and this is almost a year later. I don’t have Gfur Pro either.

I am using Material Domain = Volume, Blend Mode = Additive (Automatically Set Usage in Editor = True). I try and make a Niagara system and use this material and get the following error:

[SM5] /Engine/Private/VolumetricCloud.usf(118,33-53): error X3018: invalid subscript ‘VertexId’