Non collision water surface

Do you mean your water plane has collision and you want to remove it or do you mean the volume isnt working as expected?

Anyone knowhow to make the surface of water in sea, pond or lake so that I can hop in and go into the water? I have made the volume but have no non-collsion surface.


Ok. Then you’ll need a physics volume to imitate underwater physics and a plane mesh for the water surface. If you search the forums there are also a couple of plugins/shaders to create dynamic ocean if that is what you want.

Thx for your feedback Jacky.
I have no water plane and want to make a nice looking one. I will have to deal with the volume later.

Hey pkringen,

Here is a video of a good way to set up your initial water mesh and volume:

After getting your setup complete there are a few more things needed so when you enter the volume the characters physics are changed to swimming mode and you are able to move around freely.

Steps to follow:

  1. Open up your level blueprint and make sure your volume is selected in the editor.
  2. Right click in your event graph and with the volume selected create an “OnActorBeginOverlap” event.
  3. From there pull off a node from the execute pin and create a Cast To “MyCharacter” (or whatever your character blueprint is named).
  4. From the “As MyCharacter C” create a “Get Character Movement” node.
  5. From the “Cast To MyCharacter” execution pin create a “Set Movement Mode”
  6. Change the movement mode from the dropdown box to Swimming
  7. Connect the “Character Movement” node to the target pin of the “Set Movement Mode”
  8. Now go into your Project Settings and click on the “Input” section.
  9. Add a new Axis Mapping and label it something like SwimUp.
  10. Bind your desired keys in which you want the character to swim vertically.
  11. Set one of the keys to 1.0 to swim up and the other to -1.0 to swim down.
  12. Now go into your “MyCharacter” blueprint EventGraph and create a new “InputAxis” node and find the Input axis you labeled SwimUp
  13. Pull off a pin from the execution of “InputAxis” and create a new “Add Movement Input”
  14. Set the world direction values to X = 0.0, Y = 0.0, and Z = 1.0
  15. Connect the “Axis Value” from the “InputAxis” to the “Scale Value”
  16. Compile and save your blueprint.
  17. Finally go into your “MyCharacter” blueprint and within the defaults tab type in the search box “Buoyancy” and set it to a value above 1.0
  18. I set mine to 1.1 but you can experiment with this value at a later time.
  19. Test your water volume to see if it works!

Compile and Save your work. I have attached three images in order to help you with the set-up process

Let me know if this helped fix your issue or if you need further assistance.


You want to search for your character’s type name. If your character blueprint was called PlayerCharacter you would cast the actor to PlayerCharacter. Unreal template projects use MyCharacter as a default, but it can be named anything.

Hi and thx for the feedback.
I got some way through but cant find the “Cast to my Character” volume and thus I am stuck…

Hello, pkringen

I actually realized the step that I asked you to create the “Cast to MyCharacter” comes from the “Other Actor” pin of the event “OnActorBeginOverlap,” and not the executable pin. So pull off a string from the little blue pin named “Other Actor” and type in the search field “Cast to MyCharacter.”

Hope this resolves the issue, and apologies for incorrect direction.