Download

Noise: Low Freq Enabled problem

I have a beam which works fine until I tick the Low Freq Enabled option under Noise.

Without Low Freq Enabled it’s effectively a straight line between the source and the target (as it should). I want noise (to make it look like electricity), so naturally I ticked Low Freq Enabled. The noise works, and it does look like electricity. **But: **I receive some random direction noise (lines going random directions, not toward the target). The target receives the main beam and it looks great, but there’s also a high number of what appear to be artifacts going in random directions or (what looks like) an attempt to fill some gaps between particles. I don’t know why, and I’ve tried tweaking a high number of different options.

Before I come back and put in screen shots of all my different parameters I thought I’d ask here, just in case this is a common problem with a straight-forward solution.

Update: the culprit seems to be interpolation points.

If I set interpolation to 0, I get no random direction noise, but the beam does not reach all the way from source to target.

If I set interpolation to 1, then the beam appears to bounce off of some far away location before going to the target.

If I set interpolation to some random higher number (e.g. 50) I get many bounces of the beam off of these interpolation points, which appear to be everywhere. It’s a chaotic mess.

Any solution to this so that my beam can reach to the target without interpolation points?

I solved this issue.

The Texture Tile parameter in the Beam Data is set to 1 as default. This means that without interpolation points it will only spawn one tile - not long enough to reach the target. Intuitively I used distance to try to get the tile to stretch over as part of the beam, but again without interpolation points this did not work.

I solved the problem by setting Texture Tile to 0. With that, I was able to set interpolation points to 0 as well, and the beam reached the target.