Download

Noise in specular surfaces

Hi
I am running on the latest Alienware 17 R5 laptop (880M 8GB GPU / 16GB RAM / HD Screen). Everything looks fine and all the samples run at 40-60FPS. But strangely there is one rendering artifact that refuses to go away no matter what settings I try. All surfaces with high specular seem to be very noisy (TV, metal parts of the chairs, shiny ground etc). The noise depends on distance to surface and angle. If you get close to the TV in the Realistic Rendering demo the noise goes away for instance… Please suggest a solution. Screenshots attached:

3651f57eb575e73fe29e4a69da3a25bcb63a566a.jpeg
db9fb3b08c739c04b43718f1c873565d6d44eb47.jpeg

Thx
Sanjit

That’s intrinsic to the technique used. UE4 uses a mix of cube map and screen space reflection, it samples the picture and scattered reflection points of the enabled materials followed by a temporal accumulation. The noise will be less noticeable if you raise the material roughness as it blurs the reflection, but for Mirror-like surfaces you should prefer to render a real reflection texture and map it on the object to keep things clean.

The point is that there was no noise when I ran UE4 on my desktop (nVidia GTX 470). Especially the TV was perfect. Yes there is some noise/blurring due to low res sampling of reflections but not the kind you see in my screenshots… This is some other issue…

Sanjit

It looks like Temporal AA is off in the apartment scene. You can find and enable it in the post process volume.

Thanks Jacky for the tip. I could not find Temporal AA settings anywhere but I managed to control the noise by playing around with the ScreenSpaceReflections settings in PostProcessVolume_1.

Sanjit

Also setting the viewport to Realtime is essential in proper AA…

After playing around a bit I think I do have a problem on my GTX 880M (8GB) Laptop graphics card - on my 470GTX Desktop the problem is not noticeable. The problem is that Screen Space Reflections are very noisy (not high specular areas as I thought earlier). The Realistic Rendering demo works find out of the box on the GTX 470 but on the Laptop card I have to tweak the settings, reduce Intensity, adjust Quality etc…

Is there a difference in the way the shaders are working ?

Sanjit

Could be due to different shader model support? I dont think the 880M has shader model 5 support :wink:

Regarding the noise, do the following: go to your post and set the SSR quality to 100. THIS DOESNT CHANGE ANYTHING^^ It just tells the engine that it is allowed to use the highest possible setting. The problem is, this setting is 3 right now, which is the value at 50 in the post.

So what you need to do is, go to the command line in the top right and type in: r.SSR.Quality 4

That unlocks the 100% quality level from the post and SSRs will get perfectly smooth :slight_smile:

Cheers!

and temporal AA is listed in postProcessVolume > Misc > click down arrow…AA Method > Temporal AA