Noise in reflections "metal"

hey guys,
I just noticed something strange on my metal lamps… the metal reflections are looking really bad, there is some kind of noise which makes the metal material look weird.
Any ideas what the problem is ? I tested the same lamp and material in a different engine, looks just fine…

That is caused by Screen Space Reflections.

You can adjust some settings with the Post Process Volume settings but keep in mind that, as the name implies, it can only reflect what is visible on the screen.

You guys really need to consider adding an option to disable SSR in opaque materials (translucent materials have it, there is no reason to be inconsistent).
At least that way a cubemap/reflection capture can be used to get clean results, even if inaccurate.

edit doh, I guess I had this window open for a while and didn’t see the other replies.

This is noise with screen space reflections. Your test case of many thing concentric rings of emissive are not a great case for screen space refletions since it is hard for the tracer to find a good location. You can try using a post process volume to increase the quality of screen space
reflections but I would still expect a bit of noise for this. A better solution would be to disable screen space reflections and place a small sphere reflection capture if this is an important scene. Make sure you have some static lighting and rebuild.

I agree that more SSR options like disabling for some materials would be great.
Adik, try some console commands to play around with settings while playing in a standalone game. These might have very little effect since SSR won’t work well anyways in your confined space there.

“r.ssr.temporal 0” and “1” Sometimes adds or reduces noise based on the Temporal dithering
“r.ssr.quality 4” More SSR refinement. Beware of big performance hit
“r.ssr.quality 1” Sometimes gets rid of noise and instead makes it look like a mask.

ok thank you very much guys! I thought the problem is on my site… i will try the sugested work arounds/solutions for this problem.

r.ssr.cone seems to work for editing this as well, I’ve run in to a simmilar problem to this. the ‘quality 4’ setting is really the only acceptable result I’ve been able to get from messing around though.

I get round this by overcranking the resolution- r.screenpercentage 200 will make ssr look much nicer.

That’s not practical for interactive scenes or games, but is fine for screen shots.