Nodes disconnecting while packaging, packaging fails

I get the problem that nodes which are connected in the editor seem to get disconnected while I try to package the project, so the packaging fails. The log while packaging says:

LogBlueprint:Error: [compiler UnitCommandManager] Error This blueprint (self) is not a UnitSelector_C, therefore ' Target ' must have a connection.

And this a few more times than once. UnitSelector is a UMG widget and I often get the problem that the UnitSelector references are changed to REINST UnitSelector references while I compile other widgets, most times just compiling every single widget from the bottom up to the parent one fixes the REINST bug, sometimes I have to actually delete the UnitSelector widget out of all widgets, add it again and replace all references manually with the new one.

It’s because I have cyclical dependency in my widgets I guess, I often directly reference the parent widget in the child.

Is this a known bug?


I went ahead and double checked for you. There are no reports matching the information given in your post. If you would like to provide additional information, I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Where you able to reproduce this issue in a clean project?
  2. If so, could you provide the steps needed to reproduce this issue on our end?
  3. Could you provide screen shots of the blueprints involved with this issue?
  4. What platform are you packaging out to?
  5. Have you made any recent changes to your widgets that may have caused this issue?
  6. If so, have you tried using one of the auto generated back ups?

Hi Rudy,

Thanks for letting me know it’s not a known bug.

1 I have not tried to reproduce this in a clean project, building blueprints with heavy cyclical dependency is something what just happens over the months

3 I don’t think there’s anything special in the widgets to show

4 I am packaging to Windows 64 bit

5 The change I made was updating to 4.9. The REINST after compile bug occured in 4.8 too, but the packaging worked there. I made a lot of changes to all widgets in recent time, and I probably added more and more cyclical dependency

6 Since there are no specific special changes I can’t use any backup


If you run an is valid check to see if the value that is getting the REINST error is valid, does this issue still occur?

The issue still occurs with using a IsValid before any references to the widget. Why should it fix it? Now the wire between the reference and the IsValid node is just disconnecting and this gives the error while packaging.


To answer your questions about my suggestion, sometimes the REINST error is given for a null value. I wanted to double check that, that was not the case. Would it be possible for you to send me your project in a private message so that I can take a closer look at exactly how everything is setup?

I will try to. It’s 12GB at the moment so I hope I can reduce the file size a bit.


I tried opening the project several times and I have run through the steps that you provided, however I was unable to get the REINST error to occur. I will try a few more things. I did want to mention that I saw a lot warnings and a couple of errors that I was able to clean up by removing unnecessary cast nodes. Two blueprints that come to mind were “Main Tab Switcher” and “Unit Command Manager”. I had a few more blueprints that were throwing up errors and I did some similar maintenance on them as well. After this I was able to modify blueprints and Play In Editor without issue. I was wondering if you were able to reproduce this issue in the project that was provided?

On a side note: Your project looks like it is coming along nicely.

Hi Rudy,

The cast nodes I have added after you asked about trying to use IsValid, just since I thought if I cast to something then maybe even a REINST node will not disconnect since I should be able to cast anything to anything else, and I think the cast actually helps a bit since less nodes are disconnecting now, at least it feels like that. I have added a lot more of these “cast to itself” nodes after I sent you the project.

You have said you are able to play in editor, but this bug is primarily about that the packaging fails. I actually have not got the disconnected nodes after a project restart the last days, I think maybe all the cast nodes fixed it. But I still have a lot of problems with the general cyclical dependency issues, so I compile one widget and a lot of other widget get compile errors and I have to compile them all manually to fix it. You have not gotten such errors after doing stuff in the blueprint I described to you in the message on the forums?

Have you tried to package the project? It should fail with the error I described in the first post here.

And thanks for the nice words about the project, the one I sent you has really crappy graphics because I tried to delete as much as possible, so please don’t judge on the graphics :slight_smile:


I was able to package the project without issue and I did not run into any REINST errors. However, please keep in mind that the project that I was able to package was the one that I cleaned up a bit (as mentioned in my previous post). I will create a fresh version of your project from the zip file that was provided and try to package it out as it was.

Ok, I’m awaiting your result :slight_smile:


The project that was sent before modifications did not package out. I have sent you the project that I have been able to package. I would like for you to look it over and let me know if it is functioning correctly.

Thanks Rudy, answered your PM in the forums :slight_smile:

Have you seen my PM in the forums?


To answer your question about the changes that I made to the project to get it to package, you would be correct. All I did was remove some cast nodes and replace them with direct connections in your project.

As for your question about if I followed the steps listed in your first message. I did in fact follow them exactly and I tried multiple times with slight variations to try and reproduce the REINST Error but did not meet with any success.

I am having send a copy of the project that I changed via drop box (We cannot link to others outside of epic using our google drive).

As stated before, could you take a look at it and make sure that things are working as intended in your project.

However, I would like to point out that deleting the saved, binaries, intermediate and build folders (when it was zipped down originally) may have contributed to the differences. This may be worth trying in a COPY of your project.

Thanks, downloading it now from Dropbox.

I have already tried deleting all the folder you mentioned but it has not improved anything. It has reduced the filesize, so that’s fine too.

Since when I created this bug report I did not have any unnecessary cast nodes in my project they can’t be the cause for the problem. You say that you were not able to package the project in the state I sent it to you, that means there is some problem there, right?

It’s unfortunately that you can’t seem to be able to reproduce the REINST issues, I think I have tried with the exact version I sent to you (before I sent it to you) and I was able to get the compile errors in all the blueprints. They also constantly happen in my full project so I really need to have this fixed in 4.10, they make working on this project really a pain since a third of my time I’m spending on fixing broken references and manually compiling all the blueprints.

I will look through the project you provided and see whether I see anything special there, but if I don’t find anything, what would you advise me to do now?

I just tried the steps I described to you in the first PM in your version of the project and I was able to reproduce the disconnecting nodes and REINST errors appearing in a lot of the blueprints. I have also recorded it so that you can take a look at it. I will send you the video in a PM.

I have tried to package the project and it failed with a lot of REINST errors.


After watching your video I was able to reproduce this issue on our end. I have written up a report ( UE-21793) and I have submitted it to the developers for further consideration. I will provide updates with any pertinent information as it becomes available. Thank you for your information and time.

Make it a great day


I wrote a report for the REINST error because I was able to get the project to package out with out any issues after clearing out the warnings and errors.