No user projects found

Since 3/31/2015’s update my launcher now shows white text saying “No user projects found” instead of all of my projects. My project’s folders are still there.

Having the same problem here. No user projects found. You have to launch a version of the editor first and pick it thru the Projects window there. NARF!

Hi Hitpawz & 1I2Hawk,

Try opening a project directly from your Project folder, close it, then restart the editor. The Launcher should pick it back up. Let me know if it works or not.

When I open the project from its folder, it also opens up the launcher but it still doesn’t recognize any of the projects. I’ve opened and closed the editor and launcher in a few combinations now with no luck.

As per 1|2Hawk’s post, we can still open the projects, just not from the launcher for now.

1 Like

Hi guys, can you tell us what kind of projects you had? Were they located in “C:\Users"Username”\Documents\Unreal Projects"? Were they code projects or blueprint projects? Also, how old are the projects and what engine version were they made with?

My UE4 directory isn’t my C: drive, rather another drive.

My projects are all located at

E:\UE4\Epic Games\4.7\Projects (or their respective version folders).

Some of the projects were created originally in 4.5 and others in 4.6 and one or two in 4.7. None of any of them show up in the launcher.

Hi guys,

We’ve been able to reproduce your issue here and can confirm that the latest update did cause this. We’ve put an issue in our database and we’ll wait to hear back from our development team to see if this is by design or not.

It is also highly recommended that you DO NOT save project files within the engine file path as it possible for issues like these to occur.

-Max B.

Is there any known work-around for this problem? Makes adding packs bought on the marketplace to projects quite difficult if the projects don’t appear in my projects.

Hi PhilPix,

Like I mentioned before, make sure you don’t save your projects within the Epic Games folder file path. If you already have a project there, you can easily move the project file to a new location. You will have to manually open it again once moved to the new location but the launcher will remember the path and it will show up in the library.

-Max B.

Hi Maximusdb3,

I run into the same issue, using launcher 2.1.3-2533468 and unreal engine 4.8.0 preview 4, on Windows 7.
No mater where I put my projects (I tried to create C++ projects), under default unreal project folder, on my usual dev stuff folder, or even directly on C:, the launcher does not see any project at all. I Also tried what you said, launching manualy, then close, and open again → the launcher still don’t see any projects.

Is there a way to load marketplace packs in our projects without the launcher ?
Thanks,

Hi guys, same problem since 4.8.0, no matter where are my projects located. Any solution found?

I’m getting the same issue but so far only with 4.8.0. My 4.6.1 project is still showing but no matter where I put my 4.8.0 project folder it still does not show up. Unfortunately I just bought something off the market place for it.

Hey all,

I think i have a couple workarounds for you to try. Firstly, move your projects to somewhere safe if necessary where you’d like to work from like Maximusdb3 says.

  • Now, from in the Launcher, download BlackJack, or something or your choosing from the Learn tab.
  • Use Create Project to make a BlackJack project, and browse to the same route as the folder you dropped all your projects into.
  • When you make a blackjack project next to your others, it should give the Launcher a kick to also find the other projects there!

Alternatively, if you prefer and like playing with ini files, you can go and add your project locations to the Game.ini yourself.

  • Navigate to: C:\Users\[username]\AppData\Local\EpicGamesLauncher\Saved\Config\Windows
  • Open up Game.ini and add lines to the end like the following:

[Launcher]
CreatedProjectPaths=E:/MyUEStuff
CreatedProjectPaths=E:/LearnUE

Of course, change the paths to the ones you actually use, and list as many ‘roots’ as you have, as in, the folders where all your project folders are, not the individual project folder, if that makes sense.

Let us know how you get on!
Thanks,
Leigh

1 Like

This worked for me, thank you!

Doing the ini edit, there is one thing you need to be aware of about nested folders.

If you have a .uproject located at: E:/MyUEStuff/Project/Project1/project1.uproject

The launcher will not recognize it. You need to have the location set to:

E:/MyUEStuff/Project1/project1.uproject

Or, you need to add (to the game.ini as above):

CreatedProjectPaths=E:/MyUEStuff/Project

It is only parsing 1 folder deep, not all of the folders. I hope this makes sense. Sleep is beckoning.

1 Like

Yes that is correct, thank you. You must add each folder that contains project folders created by the editor. We do not do a full recursive search, just 1 level deep as you say, which is the usual behaviour. Your second suggestion here is the ‘correct’ way, it is what the Launcher itself will do.

Same issue with 4.8.0.

One important thing to get it working is that you cannot use the Windows explorer search path, i.e the following path will not work: E:\MyUEStuff\Project

Instead you have to use slashes that are directed the other way, as following:
E:/MyUEStuff/Project

I ran into this issue with 4.25, trailing on what leighswift provided, I did the following.
in C:\Users{user}\AppData\Local\UnrealEngine\4.25\Saved\Config\Windows\EditorSettings.ini
under: [/Script/UnrealEd.EditorSettings]
add: CreatedProjectPaths={your projects path}

All my projects now show in 4.25

– THIS PERFECTLY WORKS –

1. Go to C:\Users\AppData\Local\EpicGamesLauncher\Saved\Config\Windows\GameUserSettings.ini
2. Change the path to the path where your projects are present.

1 Like