No static shadows on static mesh

I was setting up the lightning for my level - I am using a Static Directional Light and a Static Skylight, when i uncheck cast dynamic shadows either on the static meshes or the lights the shadows disappear. I checked if the UV channels are ok, played with the lights mobility, reimported some of the meshes,but Ii still have the same problem.So if someone could help me out, maybe I’m missing something simple. Thanks

Hey Trekz,

First thing to check is to make sure you have rebuilt your lighting, and placed a Lightmass Importance Volume encompassing the area in which you need static lighting. This will help reduce light build times and increase the indirect lighting in those areas.

Be sure your project settings has the ‘Allow Static Lighting’ enabled and your light sources have cast static shadows enabled. A few screenshots of your scene would really help me visualize your issue.

Thank you,

A few images with the settings i have on the directional and sky light as well as the post process volume. The shadows on the static meshes work but they are dynamic, if i uncheck cast dynamic shadows they disappear :/. Btw for some reason the shadows on my BSP geometry are quite brigth, maybe it has something to do with the problem.

It sounds like you are using a ‘Stationary’ Directional light and trying to use both ‘Static’ and ‘Dynamic’ shadows, but have not set up their transition distances yet.

Shadow Casting

The documentation link has some helpful information about this approach, and how to get your shadows to display correctly by modifying your Cascaded Shadow Map settings.

Let me know if you are still having issues, or if you need further assistance.


Thx for the response, i read the documentation and after that found this thread:

From what i get it’s pretty much the same problem i have. So if i put a value of 0 for the Dynamic Shadow Distance then the directional light would cast only static shadows and they will work correctly, am I right ? I don’t have a problem with the shadows as they are - dynamic but i would like to optimise my light building time. I am still not sure what I should do about the BSP shadows, i played with the Light Res and the materials applied but i don’t think it’s from that. Anyway thx again for the help .

Hey Trekz,

Yes, if you keep your ‘Dynamic Shadow Distance’ at 0 you are effectively disabling the Dynamic Shadows. This number represents the distance in which your Dynamic shadows transition in over your static shadows.

Dynamic Scene Shadows

Take a read over this for more information on this topic, but let me know if you have further questions.

Thank you,

Thx i’ll check it out, and play with the values for the Dynamic Shadow Distance. If there is anything, i’'ll let you know. :slight_smile: