Download

No static shadows after backing. Inderect lighting goes through objects

I’m trying to bake lighting, but I faced the problem that baked indirect light isn’t blocked by meshes and spreads across attenuation radius as if light source had “Cast shadows” disabled
Before baking:


After baking:

All meshes are static and have “Cast static shadows” enabled. The light is stationary with default settings. I’ve made this scene specifically for testing this issue, so it has all settings set to default

1 Like

What is the lightmap resolution of the floor?

Resolution is fine here (1024), density is green in visualizer

Hi!

You can try to use two sided material…
BUT imo the main problem is that your walls don’t have thickness!!

I’ve tried blocking light with thick cubes but it didn’t help


Making it two sided didn’t do anything either

Is the light set to cast shadows as well?

Yes, light casts both static and dynamic shadows

Well at least these walls DO get proper lighting! :wink:
Is your floor also a plane with no thickness?
Do you have lightmassimportancevolume around your scene?
All your meshes are Static?
How big is your floor mesh?

Ok, I think I found out what’s the problem. It seems like a typical light leak but greatly “multiplied” by the post process exposure (seriously, why would epic set such ridiculous values as a default?). And it seems like my meshes don’t have enough padding in lightmap UV. I’ve cranked up resolution and quality settings to the maximum and got a result with only a little bit of leak
Also I’ve tried GPU lightmapper and there wasn’t such problems, thought it didn’t work with stationary light. But that’s a different story