Download

No sound in VR game for a customer

I’m stuck.

I have a user who is using an HTC Vive and reporting that they are not getting sound in my game and they’re not getting sound within “The Brookhaven Experiment”. They are able to get sound with every other VR game online.

I created an empty project and put a sound asset in there which plays 2 minutes of music, all with default settings. Then I packaged it up, tested it, verified that it works on my hardware and has sound, and then sent it off to the user. They tried it and reported that they don’t get sound.

Could it be an engine problem?

I asked him to send me a list of all the VR games which he gets sound in. Here’s his list:
5089
Cosmic Trip
Draconic Order
Job Simulator
Kismet
Left-Hand Path
Out of Ammo
Pipejob
Rec Room
The Solus Project
Soundboxing
SoundStage
Spell Fighter VR
Subnautica
Surgeon Simulator VR: Meet The Medic
Surgeon Simulator ER
Tabletop Simulator
Tilt Brush
Universe Sandbox
Vanishing Realms
Windlands
Craft Keep VR
Sword Master VR
Waltz of the Wizard
non steam game Yiffalicious (This one I know for sure is made in unity)
The Lab
Holopoint

We know that “The Solus Project” was made in UE4, and if he’s reporting that he gets sound, then it can’t be an engine specific problem (unless its a specific engine version problem).

What we know:
-Using SteamVR with HTC Vive
-Sound works with “The Solus Project”, which is made in UE4
-Creating a blank, vanilla UE4.13 project which plays sound works when NOT in vr, but FAILS when in VR.
-Using the audio port on the back of the Vive
-user is on a laptop with NVidia GTX 950
-All drivers are up to date
-All unity VR games work without any issues

Any answer for this? Experiencing something similar where audio is working on some machines, but not on others, with very little to go on as the specs vary. It’s only an issue with cooked/packaged builds, seems to have started when we switched to UE 4.15.

Is there an Oculus plugged in at the same time? You could be hitting something similar to this: Audio goes out on the Oculus Rift headphones even if -nohmd is passed on the commandline - UE4 AnswerHub

No, this user was using an HTC Vive.

I had some issues with the headphone jack in the Vive Pre (HTC says it’s a known hardware issue), but this user was using a release version of the HTC Vive.

I know that this is an older post, but I’m running into a (Slightly) similar issue. I’m using the HTC Vive (UE4 4.16.2), and my project’s sound works perfectly, unless my Vive is not already turned on when I play the build. I have exhausted all other forum posts and it’s only when the Vive is not running before I launch my application does the audio not play. I was wondering if anyone has solved either your original problem (They may be related) or my problem.

We’re getting reports of this too. Any idea how to solve this?

I think this might be a Steam VR & Vive specific problem. I’ve noticed that sometimes when I have my headphones plugged into the vive headphone jack and the HMD is asleep or not in view of the light houses, I get no audio. However, if I move the HMD, it wakes up and my audio resumes. I have experienced this by having a browser tab playing music on youtube, so it’s not even related to games. I would probably consider your problem to not even be a real problem to solve because the remedy is to just launch the game after the vive is turned on.

No idea. I can’t reproduce this myself. I’m a solo indie, so my QA resources to test what could be a hardware or driver problem, are non-existent.

Digging up this issue as well. Customers QA claim to have issues related to audio not playing after lanuching the packaged project (VIVE only, Windows 10). I had experience with this kind of issue however I always clicked anywhere in the screen with a mouse to make the window active and been doing VR and Unreal on a range of PCs and laptops. Customer is claiming that this might be Unreal specific bug since other titles developed with Unreal seem to have it common. The titles being Brookhaven Experiment, Amazon Odyssey.

Sadly I’m not able to repor the issue since it is working fine on either the headphones plugged through jack and in-built monitor speakers. The project itself doesn’t use any kind of audio systems running in the background. I assume it might be the case with Windows itself and how Unreal apps are handeled, what I mean here is that sometimes the app upon launch is started in the backround (running as non active window). As I mentioned earlier simply clicking on the window seemed to solve it and audio was always running after that. Dunno whether it might be the case here but build is distributed over on Viveport, hasn’t been published on Steam yet.

Tagging [USER=“14973”]Chance Ivey[/USER] here, as you might have any kind of knowledge related to the issue. (yeah I tagged you over on Discord as well ;P)

So, thanks to guys over at Discord, there seems to be a solution to the issue. In DefaultEngine.ini add the line below:


[Audio]
UnfocusedVolumeMultiplier=1.0

Shin-ji, thanks for bringing some light to this issue, eventually!

Must the project be build with this DefaultEnginge.ini setting? Or can I slip this ini file into a packaged game config directory and have a very small update?

Personally I’d go with doing this through project files DefaultEngine.ini, it might be possible to overwrite the file in question in a packaged build, however haven’t got any kind of experience with that. This link might be helpful though for anyone looking to modify the file in a packaged build A new, community-hosted Unreal Engine Wiki - Announcements and Releases - Unreal Engine Forums,Read%26_Write_to_Config_Files

So I am the customer referred to here. After months of hunting for the solution to this I have FINALLY hit upon the answer today and wanted to share…

It really is simple in the end. Today I hit upon a comment in a thread about the 202 compositor error. This turned out to be the answer.
If you move the position of your “monitor” (HMD) in relation to the others it is less likely to happen (i.e. compositor issues) from other windows opening on it.

Within display settings you have to drag the second display (ie in this case the HMD) from its default position on the right of display 1 to the left instead:As the post I read correctly suggested, after making the change, Unreal opened on display 1 and didn’t interfere with the Compositor on display 2! It literally seems that Unreal is set to default to whatever display in on the right?!

Finally have sound in Unabomber, Amazon Odyssey, Brookhaven etc.

Steve