No Sound Attenuation in Sequencer Audiotrack

Hi, it seems like sound attenuation doesn’t work at all when adding sound cues in Sequencer, using Audiotrack.
If I place a cue in a level and start simulation, attenuation works perfectly. But if I place the same cue in an audiotrack of sequencer, it plays at the same level no matter where am I in the level. I tried overriding attenuation both in cue edit window and in cue details panel, nothing works.
Ideally, I guess, it should be like that: if you add an audio file to and audio track - it plays at the same level. But if you add a cue, it should work with all cue setting enabled.

It looks like the only way to make it work right for a while is to use Event track and trigger sounds using Blueprint.
Hope it gets fixed with the next update.

Hi StMalk,

I just chatted with the sequencer team – there really isn’t a concept of a master position in sequencer right now so there really wouldn’t be a position to play the sound. The intention is for the audio in the sequencer tracks to be more “cinematic” – i.e. sound designed like film/post-production. What you’re doing with triggering BP events from sequencer is probably right now the best way to get diagetic 3d audio from sequencer.

I see so it’s more like for music or voice over. Thanks for the answer, Event track works like a charm for anything anyway!

The audio track you guys are discussing is a general/master audio track. It’s similar to the audio track in matinee in that it is tied to the director track. It’s global audio/music.

You actually can add/attach an audio clip to a particular actor in Sequencer and it will respect spatialization. Before you drag the audio clip in, you need to select the actor. You’ll see that the audio clip gets added to an audio track which is under the selected actor. To make this functionality more evident in the future, we’ll add a drop target so there’s some sort of highlight when you drag the audio clip in.

However, we just tested this and it crashes when you scrub the timeline. We’ll fix this for 4.12 when it comes out in a few weeks.

1 Like

Interesting that it isnt seen as “cinematic”, i imagine this can also be of great use for creating natural sounding stereo/surround effects for elements like cars or spaceships whizzing through the screen. Where instead of having to mix a stereo track in post the game will do some specialization relative to the camera. (similar to what Dolby Atmos is doing in cinemas in realtime) Just having the control over the audio’s location and attenuation/spatialization settings would be of great use in many different situations.

Would it be possible to have access to the attenuation/spatialization settings of the audio fragment in 4.13?

Here is the current “difference” in available settings:

Hi MissStabby,

I went ahead and entered a feature request for this (UE-33080).


If I drag a cue into the sequencer, it should respect any attenuation settings I’ve created for it. If I drag the raw audio in, then sure, it could act as a global track. But I’m working on a sequencer-heavy VR project at the moment, and I’ve taken the time to rather carefully edit a bunch of audio tracks and timings. It would be fantastic to apply attentuation settings after the fact.

Hey 3DLight,

Dragging a cue into sequencer creates a 2D audio track which is not spatialized…and, as such, has no attenuation.

The original request here is still valid though. I’ve increased the community interest on UE-33080. You can also vote on it in the public issue tracker.