Download

No smoothing groups on one side

Hi,

I have a small issue with smoothing groups. On one side of my model I can definitely see the polygons like there is no smoothing groups. But they are set properly and on the other sides everything is fine. I think the light does that. Can I solve it somehow?

a6c358a65eb4059534f873c38891409bbb3992af.jpeg

45bc79bb0bd127aa804c120898cd9abf15a82aff.jpeg

Issues like this can be tricky to track down. If you are using 3dsmax try the following:

Reset Xform modifier

If that doesn’t work, try detatching the object using the subobject tools. Detatch as new object.

If that doesn’t work, try exporting and reimporting inside of 3dsmax and then into ue4 to see if the problem goes away.

It am not sure if your problem is with a bad import or actually just with the content itself. Is the second image from your 3d modelling program?

I’ve noticed sometimes you see some faceting from the dynamic shadows/lighting in a scene if there’s large polygons like with this asset. I’ve noticed it mostly with the Advanced Lighting Map included in the starter content when you zoom in on an asset. I could post some similar screen shots. See if you still get the faceting without the normal map.

Ah, if the OP is talking about the very feint square pattern apparent in the shading:

e9b166ad68546eb1d2f981b91647a7f0a9d9ecf9.jpeg

Then it is definitely just dynamic shadow precision. I thought it was more about the edges of the corners not having the specified smoothing.

It happens mostly at glancing angles. You can try messing with the shadow biasing with commands like ‘r.Shadow.CSMDepthBias x’ but it is doubtful any setting will remove the artifact, it is already pretty feint in your image compared to some I have seen.

Yes, the red cross is what I meant. I could have been more precise.

The edge smoothing is my fault because smoothing groups and normal map is not set correctly :D. I’ll try to tweak the shadows setting then. Thanks for help :).