No reflections rendering in mobile mode

Hi all. Too keep things simple i basically have a reflective elements in my scene for a mobile game but these do not render when going into the mobile preview ? i have a skylight with a cube map plugged in and 1 directional light.

Hey VolcanicWill,

Thank you for taking the time to create a new post. Would you mind telling me the mobility type of your ‘Skylight’ and if it ‘Cast Shadow’ is checked?

Can you reproduce this in a simple blank project, or is this a project specific issue?

If you are able to reproduce it in the blank project, please provide me with the steps you took so I can get the issue to occur on my end as well.

Thank you,

Hi Andrew

Thanks for the reply,

The mobility is currently stationary and is casting shadows.

I have created a brand new project and i still get the same results. i added to metallic based materials gold and chrome with a sky light in console/pc format and added a hdr to my skylight. which of course projects reflections. i then go into mobile mode and we run into the same problem.

Hey have you had any luck on this issue :slight_smile: ? Many thanks

I did do some testing and was able to get the reflective environment to work on my end, but my results were not incredibly strong. Screen Space Reflections are unsupported on Mobile so that is expected no to work.

You want to make sure your ‘Skylight’ is set to ‘Static’ and ‘Cast Shadows’ is unchecked. Then rebuild with ‘Production’ quality lighting. I would also take a look at our documentation on Lighting for Mobile Platforms to see how to correctly set up your reflections for mobile.

I would also take a look at the Reflections documentation, as it gives some good hints and clues on how to establish a good looking reflective environment. You need a good bit of contrast with varying normals and roughness to have a prominent reflective environment.


Hey Andrew. Basically just done everything you said an i have had a good scan through the links provided and i must say i’m quite happy wit the results now as my scene is now picking up some reasonable reflections and running at a steady frame rate. So thanks ever so much :slight_smile:

You are very welcome! I am glad you got your project to work correctly. I do like the stylized feel you got going, and don’t forget to get your idea and projects out to the community through the Forums!