Download

No real time shadows

hi! So I decided to use real time lighting by unticking “allow static lighting” in the rendering tab. However, everything seems flat now. Some shadows are missing, and the ones remaining are way too pale to be properly seen.

With built lighting

http://image.noelshack.com/fichiers/2017/37/2/1505244761-classroombuilt.jpg

With real time lighting

http://image.noelshack.com/fichiers/2017/37/2/1505244858-classroomrt.jpg

How can I fix this? :eek:

Without seeing the file this is a little difficult,

somethings you can try;

1.Make sure your lights are set to stationary or movable
2.Scalability settings
3.Cast shadows on lights
4.directional light shadow bias

hope this helps

Skylights can’t be dynamically shadowed by meshes, so as far as it’s concerned your walls don’t exist. I’m guessing that’s the source of your strong ambient lighting.

You’ve got a few approaches for skylight shadowing.

Shadowing from lightmaps (this may or may not work for your scene. Why do you need to disable baked lighting?)

Shadowing from ambient occlusion (you could bake this to a texture map or vertex colors)

Shadowing from distance fields (this needs to be enabled in the project settings, and has a performance cost. There’s a link at the bottom.)

Alternatively, you could alter the content of your skylight to match your desired scene lighting, or replace it with a post-process lighting feature.

This all assumes that the skylight is the culprit. What does the scene look like with it disabled?

Thanks for the help! It was a very simple fix, all I had to do was to set the lights to moveable instead of stationary. :smiley: