No prerequisite in packaged game?


This is an old one, i already posted a BR and this was supposed to be solved in 4.17 (UE-43812).

But one of my testing friends installed my packaged game on a fresh windows and couldn’t play due to missing dlls.

I sent him the good old UE4PrereqSetup_x64.exe and it worked after that. But i can’t ask everybody to do this when the game is released.

Just to be sure, i have checked “include prerequisites” but not “include app local”. Am i doing ok ?



The packaging tool gives you a runnable game without an installer, so with that distribution method, you’re expected to use the prerequisites installer if required. When you tick the box, the prereqs are packaged in this path:

If you’re looking to really deploy your game as a final distribution, you want to use the Project Launcher window (in Window>ProjectLauncher). Here you want to make a custom profile that fits your needs. I don’t believe this gives you a installable .exe that handles the prereqs, I think that’s up to you though.


We’ve recently made a switch to a new bug reporting method using a more structured form. Please visit the link below for more details and report the issue using the new Bug Submission Form. Feel free to continue to use this thread for community discussion around the issue.


Hi Daniel,

Thanks for your answer but i have reasons to believe it might not be an definitive one:

  • i remember this working well in some previous versions of the engine (long time ago)

  • in the link i put in my post, the official answer was implying this was indeed a bug and should be working

  • it would seem strange that i have to create my custom prereqs when there is a checkbox for that (that would not be the only interference between the packaging tool and the project launcher, see the additionnal directories to cook for exemple, they have to be set in the packaging options even when packaging with the project launcher).

So i’d like to hear some official voice on this one.

Thanks though :slight_smile: