Download

No indirect lighting/Pitch black shadows

Hey guys,
I got some issues with indirect lighting in UE4, to be exact I don’t have any indirect lighting at all.
If you take a look at the images attached below you can see the same scene in UE4 and UE3. While in UE3 I got a nicely illuminated room (ignoring the light shafts (why aren’t there pointlight lightshafts in UE4 anyway?? :confused:)), in UE4 everything is comletely dark.
I tried everything inside the PointLight settings (stationary btw.) or the world settings that belongs to indirect lighting in any way but the result keeps the same.
Is this a common problem or am I simply doing something wrong?

Have you tried putting in a Skylight?

I think it has to do with the PBR and the lightbuild settings,
Even though the UE3 one looks better illuminated, the UE4 looks to be more physically accurate.
Another trick you could try is to use a postprocess volume to force a certain exposure to lighten up the scene, the outside window and the beam on the floor will become brighter however.

@mze
A skylight isn’t really working for me as it screws up too many other parts of my scene

@MissStabby
But what is the problem? Is Indirect Lighting really not working at all or is the effect just too subtle?
In the UE4 documentation they’re showing IL and it does exactly what I need:
https://docs.unrealengine.com/latest/images/Engine/Rendering/LightingAndShadows/Lightmass/3FourBounces.jpg
They’re using one light with three IL bounces and it works perfectly fine, though my scene is pitch black
I might use a post process volume to brighten up the scene but shouldn’t there be a better way when there even was one in UE3?

It could be that your textures are just to dark making the effect very subtle.

What does it look like when you use the preview lighting mode, should be easier to tell if you are getting any bounce light then.

What happens if you switch to a brighter material?

If it is working but to subtle, either you need to tweak the base color of your materials to something a bit brighter or boost the amount of indirect bounced light. Don’t remember the name of the parameter but you can tweak it both globally in the lightmass properties and on individual materials. I think you can even give the material a completely different color to use for bounced light in the material.

What exactly do you mean by “preview lighting mode”? The mode when I make chenges at the light or baking with “Preview”-Setting?
I brightened the textures up until they were almost white but there is no effect on the lighting at all.
Well, I tried pretty much every parameter in the Lightmass-Settings but nothing worked :frowning:

Parkar is right. Better check lighting first, then materials. Preview lighting mode is here:

http://imgur.com/zg9ZCjL

Imgur

Finally found it! Parkar WAS right indeed.
I tried changing the Indirect lighting Intensity Parameter before but it didn’t change anything. Now I boosted it up from 1 to 100 and suddenly there was a littlte difference.
Changed it to 250 now and it finally looks similar to the scene in UE3. If that’s really the right solution the default max. of the parameter slider probably shouldn’t be 6 but more like 500 so it’s easier to see

Thanks guys!! :slight_smile:

EDIT: Well, still doesn’t work properly but definitely better than before

Something that I tripped over is the direction of the indirect lighting matters.

Assuming you have a directional light and sky light element you should be able to push more light through the window. If the directional light is say pointing close to a 90 degree angle the result is a secondary indirect lighting effect.

If you are using a point light exclusively then by default inverse shadowing is turned on and which trades intensity for real world shadowing.

If you take your point light and turn off inverse shadowing you should get huge different in volume of space that the light will have an effect.

did you place a reflection sphere that encompasses the whole room?
did you try to set up a different environment color than black inside worldsettings->lightmass settings->environment color?
you can start with 0.5,0.5,0.5 and then tone down

What [PB]Aphexx suggested is correct and I will also add to that, add a skylight having a value upto (0.15 or may be 0.2) with indirect intensity (0.5 or 0.25). You can also play with your exposure, contrast settings in your post process.

Cheers,

Jalay